vCard .vcf file shows as an attachment

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: turadg, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

When I receive a message with a vCard, it displays as an attachment.  That is, 
in the message list it has a paperclip and in viewing the message it has an 
attachment "user.vcf".

I think that it's not functionally an attachment.  It's an extra component of 
the message, who sent it.  S/MIME signatures use smime.p7s attachments but 
Mozilla doesn't display those.  The same should go for vCards.


Reproducible: Always

Steps to Reproduce:
1. receive a message sent with a vCard

Actual Results:  
The .vcf is displayed as an attachment.


Expected Results:  
Omit the .vcf file from the attachments list and only display the vCard box.

Comment 1

15 years ago
Works for me in Thunderbird 0.4 (20031205) and Seonamonkey 1.7a (2003122205).
The vCard always arrives as an attachment, but it can also be displayed inside
the message, with an 'Add to Personal Addressbook' button next to it. The catch
is that you need to have *both* 'View -> Message Bosy As -> Original HTML' and
'View -> Display attachments Inline' switched on. Otherwise it stays an
attachment, and there's not yet a way to display it in Mozilla (see bug 91004).

Also note bug 91004 and bug 59631 for problems recognizing vCard attachments,
but they seem related to the MIME-type that needs to be set to the attachment.
Mozilla uses "Content-Type: text/x-vcard", but Outlook seems to use
"Content-Type: application/octet-stream" for example, which is completely wrong.
See also bug 60936, because even Mozilla is slightly wrong.
(Reporter)

Comment 2

15 years ago
Jo, I think I wasn't completely clear.  I do have those options on.  vCard 
attachments do display inline as a box with contact info.

My request is that when a vCard is display as such, it not be listed again in 
the attachments list.  Akin to how an S/MIME signature isn't listed.

When I see the paperclip on a row in the message list it looks like someone 
attached a file.  But they didn't perform the attachment, they just have their 
messages include a vCard.

Comment 3

14 years ago
In Thunderbird version 0.8 (20040913), I don't see the attachments at all, just
the usaul card at the bottom of the mail.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 4

14 years ago
It was fixed in bug 244457, but that didn't see your bug-request, because you
filed it under 'Mail&News', not Thunderbird.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.