[RFE] Dragging folders from bookmark manager to browser should open in tabs

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
15 years ago
5 years ago

People

(Reporter: Petey, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

unspecified
Future
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+

In the bookmark manager, dragging a bookmark into the browser window will open
that bookmark in the browser, however, dragging a folder to the browser has no
effect. I think that dragging a folder from the bookmark manager to the browser
should open the contents of that folder in tabs.

I have not had any personal problems with this and I do not think it is a
behavior that many people will use, but it is a behavior that would add to the
consistency of the software, which I feel is a legitimate reason to address the
issue.

Reproducible: Always

Steps to Reproduce:
1. Drag a bookmark from the bookmark manager to the browser
2. Drag a folder from the bookmark manager to the browser
3. See the difference?

Comment 1

15 years ago
Severity should be 'enhancement', not 'minor'.
(Reporter)

Comment 2

15 years ago
You are correct
Severity: minor → enhancement

Comment 3

15 years ago
confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Dragging folders from bookmark manager to browser should open in tabs → [RFE] Dragging folders from bookmark manager to browser should open in tabs
(Reporter)

Updated

15 years ago
OS: Windows XP → All
Hardware: PC → All
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050726
Firefox/1.0+ ID:2005072606
Confirming this is still happening
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
If it can be done, sure.  Not a big deal, but a neat trick.
Assignee: p_ch → nobody
Component: Bookmarks → Places
QA Contact: bookmarks → places
Target Milestone: --- → Future

Comment 7

10 years ago
Reminder: also dragging a list of uris to the content should open them in tabs

Comment 8

10 years ago
also dragging a folder to the tabbar should open in tabs
Created attachment 357128 [details]
bookmarks example

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090114 Shiretoko/3.1b3pre Ubiquity/0.1.4 ID:20090114020333

I struggled with that issue today. I tried to d&d folders from within to the tabbar but always get an alert like that one:

"Firefox doesn't know how to open this address, because the protocol (mozillahttp) isn't associated with any program."

We should have the d&d of folders implemented correctly that way or disallow dropping of folders on the tabbar. To reproduce simply restore the attached json file.
Do we wanna handle that issue in this bug or shall I file a new one?
Keywords: testcase
the strs are:
- create a folder with a name NOT containing white spaces (eg "mozilla")
- add at least one bookmark inside the folder
- drag the folder in the content space
-> "Firefox doesn't know how to open this address, because the protocol
(FOLDERNAMEhttp) isn't associated with any program."
Blocks: 473759
Ok, moved this over to bug 473759.

Updated

10 years ago
Duplicate of this bug: 454745

Updated

9 years ago
Duplicate of this bug: 498150
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
As comment #0 points out, the expected number of users for this is actually pretty low.

I think the number of users who highly categorize their bookmark folders multiplied by the number of bookmark folders that are setup to have all of their contents loaded at the same time are low enough that implementing this feature won't be worth the costs.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.