java_vm process doesn't exit when last Mozilla window is displaying a java applet

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Joel, Assigned: Pete Zha)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5) Gecko/20031211
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5) Gecko/20031211

If I visit a page with Java and quit Mozilla while the java page is the only
Mozilla window open, the java_vm process doesn't quit, but if I visit another
page that doesn't contain Java before quitting Mozilla, then the java_vm process
exits cleanly.

Reproducible: Always

Steps to Reproduce:
1.Visit http://clients.gamelet.com/snapple/speedway/final_applet/race.html
2.Let the applet load.
3.Open a terminal window and run top and verify that java_vm is running.
4.Make sure that there is only one Mozilla window open and that it is displaying
the Java applet.
5.Quit Mozilla and notice how the java process sticks around after the
mozilla-bin process exits.

Actual Results:  
java_vm process doesn't quit.  If the last Mozilla page closed doesn't contain
Java, then java_vm closes as expected.

Expected Results:  
java_vm should end after the last Mozilla window is closed regardless of the
contents of the last Mozilla window.
-> oji
Assignee: general → kyle.yuan
Component: Browser-General → Java: OJI

Comment 2

14 years ago
What jre version are you using? I can't reproduce this on both Linux & Solaris
using Mozilla1.7a + jre 1.4.2.
(Reporter)

Comment 3

14 years ago
I'm using 1.4.2 patchset 5.  It's the FreeBSD native version.  I tried it out with the Linux Java under 
emulation, and the problem doesn't exist, so it seems to be a FreeBSD specific problem.  I'll let 
them know about it, sorry for the noise.

Comment 4

13 years ago
I have also experienced this problem on my windows xp pro service pack 2
machine.  I am running mozilla firefox 1.0 final and java 1.4.2_05.  Whenever I
go to my pix's pdm page (a java applet) and then close firefox, the java vm
keeps running and I am unable to open another instance of firefox unless I
manually kill the instance that is holding the java vm open.

Updated

13 years ago
Assignee: yuanyi21 → pete.zha
(Reporter)

Comment 5

13 years ago
I believe this has been fixed for a long while.  I don't have a FreeBSD box around, but I'm pretty sure you 
can close this as I haven't seen anything in the FreeBSD mailing lists to indicate that this is a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.