Closed Bug 229343 Opened 18 years ago Closed 16 years ago

unable to create new folder with custom install (win98,NT4)

Categories

(Firefox :: Installer, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: hao2lian.bugzilla, Unassigned)

References

Details

(Keywords: helpwanted, relnote)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031223 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031223 Firebird/0.7+

Just like the Mozilla installer, the Firebird installer should allow the user to
create a new directory on the hard drive in which the Firebird files may be
installed too. Currently, if you type in something such as "C:\Program
Files\MozillaFirebirdthisisanewfolder" into the "Browse" box, the OK button
simply greys out.

Reproducible: Always

Steps to Reproduce:
1. Download a 0.8 branch nightly installer.
2. Run it and choose the Custom installation.
3. Click on "Browse".
4. Type into the field "C:\Program Files\MozillaFirebirdthisisanewfolder".

Actual Results:  
The "OK" button greys out.

Expected Results:  
It should've kept the "OK" button active so that the folder
"MozillaFirebirdthisisanewfolder" will be created under the Program Files
directory for the Firebird installation files to be installed into.
Severity: normal → enhancement
This just in (courtesy of Silver): On 2000 (and probably XP), there is a "New
Folder" button in the Browse dialog box.
Summary: Installer should allow user to create a new folder via the Custom installation → Installer should allow user to create a new folder via the Custom installation excluding Win2000/(XP?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Installer should allow user to create a new folder via the Custom installation excluding Win2000/(XP?) → Installer should create new folder if entered via the textbox and path does not already exist
On Windows NT there isn't even a text box. (The directory field is an uneditable
label, and clicking on "Browse..." shows a dialog with just a directory tree
selector.) So specifying a target directory requires first creating it with some
other tool, then navigating to it in the installer.
(In reply to comment #1)
> This just in (courtesy of Silver): On 2000 (and probably XP), there is a "New
> Folder" button in the Browse dialog box.

On my (german) Win XP SP1:
the new Folder button exists, but it didnt show me the new folder... it just
created a "new folder" folder under "Programme" (German for "Program Files"),
didnt show me the "+" Icon to open "Programme".

The default behaviour in theese dialogs is: 
Clik on new folder, the view changes to the new folder and goes directly to
editing the Name of this Folder.

btw: the default folder Chooser in most Installer has the option to just type in
the Name where its installed
In WinXP Pro:

1. Select "Browse..." in the installer
2. Select the "Program Files" directory
3. Click "Make New Folder"

And a new folder is created, and it is in the rename state, you can type in a
new name.

4. Click "Make New Folder" while the new folder created at 3. is selected

This time, a new folder is created, but it is not in the "renaming" state (it
should be.)

5. Enter random text into the text box

The path to the folder with the name as typd into the text box should be passed
back to the installer. Instead, whatever is selected in the tree view is passed
back and displayed in the label.

Using an installer downloaded just now (see date stamp).
The New Folder button works for me, but the installer is then unable 
to "create" the folder because I already have and it quits without any more 
options. There is no way to install it anywhere other than "C:\Program 
Files\Mozilla Firefox" because the installer forces you to create a folder for 
it then it won't put it there because it has already locked the folder 
preventing itself from removing it.
Unless there's another bug that covers this issue, I don't think this is an
enhancement - on Win98 (maybe FE only), NT4, both both on the list of supported
OSs, and Win95, there is no "new folder" button, which means it's not possible
to install into a new folder using a custom install.
Severity: enhancement → normal
I can confirm this on MS Windows 98, not Second Edition. The installer for
Firefox 0.9 (final) doesn't give any opportunity to create a new folder. This is
very annoying, I was also going to file a bug on this one.
So the fix to this bug would be to implement the "Make Folder" button
functionality available on other OSes? If so, the summary needs to be changed.
I don't think so. The dialog used is a Windows standard dialog. Older versions
of Windows don't have the new folder button on it, and it's not possible to
change that. You'd either have to use a different standard dialog (which is what
Seamonkey's installer does), or make it into a custom dialog, or handle the
response differently.

I don't think we need multiple bugs for this - the issue is that you can't
create a folder with the installer on NT4/98 first ed (and 95, although that's
not supported), and it can be left up to the developers to figure out how to fix
it. I'll change the summary to reflect that.
Summary: Installer should create new folder if entered via the textbox and path does not already exist → unable to create new folder with custom install (win98,NT4)
*** Bug 250019 has been marked as a duplicate of this bug. ***
At the risk of stating the blindingly obvious, this also happens on the new
Thunderbird installer.
Flags: blocking-aviary1.0?
Not stop ship. May re-consider if a patch appears soon (re-nominate in that case)
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
Keywords: helpwanted
With 20040910 nightly:

Clicking "New Folder" button worked after I selected "c:\Program Files" as the
parent folder.

Editing the name "New Folder" in the text field did not work (the text field
changed, but when I clicked OK, the new name was not used.)

Editing the name "New Folder" in the dialog's directory tree did work (it was
used when I clicked ok).

I suggest getting rid of the text field.  It is not clear what the text field
means (it is not a full path).  It is confusing two have a name in two places,
and clearly the program doesn't how to pick the most recently modified place.
With FF 1.0PR on W2K/German
- if I choose 'custom' installation
- click 'browse' to change installation folder
-> the tree opens with the 7z temp directory selected (clearly not the place to
   start from);
   I would have expected something like c:\Program files
- if I navigate to an existing directory and press the button 'new folder'
-> nothing visible happens !!! (no new folder shows up);
   however with an external file browser I can see the new folder;
-> the problem is that the tree is not updated
   (pressing F5 or closing/opening subtree doesn't help)
- to see the new folder I have to 'cancel' the selection window and press
  'browse' again
- now I can see the new folder
- but if I want to rename it I can click in the tree and rename the folder,
  however after pressing 'return' the old name appears again
-> the same problem as before: the tree is not updated

Both problems
1) wrong start directory
2) no update of folder tree
should be marked as show-stoppers since a user new to firefox will get bad
impressions before he/she can run the program.
This gives a very bad first-time impression of Firefox 1.0PR in my opinion (And
I don't even remember seeing a "new folder" button, wasn't it just called
"choose another folder" or something like that?). Just like #14 I started with a
temporary folder when selecting a new folder, and wasn't able to create a new
folder from inside the installation program (Win 98, FF1.0PR1).
It was my first try with Firefox, but I have been running Mozilla for years.
Seems like a weird start. Have Never seen an installer with this restriction
before, and don't really understand it's not a blocker?

(BTW. Firefox didn't automaticly (or asked me if I liked it to) import any of my
bookmarks (or settings) from Moz1.7.3 or IE6 upon installation. Any idea which
bug this is? It's problably there, but can't find it. Couldn't find the
import-wizard after the installation either, until I saw it described where to
find it in some bug-report. Yees, I had a good first-time experience with FF...)
(In reply to comment #13)

Confirming on Win98SE / FF 1.0PR.

Setting as a custom install then entering a new non-existant folder name on
drive D resulted in it requesting to install into D:\Temp\7z5355.TMP instead of
the folder I requested (D:\Temp being the system temporary folder). Creating the
directory in question solved the issue, but the installer needs to check whether
the folder exists when entered into the dialog box, and if not, request to
create it before attempting to assign it.
*** Bug 266628 has been marked as a duplicate of this bug. ***
FireFox 1.0PR on W2K/English 
(Confirmation of Comment #14 From Timo Boehme  2004-09-15)
- Custom Installation
- Selected 'Browse' to change installation folder
- Was expecting dialog box to have 'C:\Program Files\Mozilla FireFox' in the
entry widget, but instead had '7zSBC.tmp'
- Expansion tree widget displayed location names instead of drive letters.
Selected D:\ drive and entry box loaded 'Programs (D:)'. ('Programs' is the name
of my D:\ drive)
- The double-click method of selecting installation location via expansion tree
is totally unusable.
- The 'Cancel' button in the Browse dialog box also did not return to the
original installation path.
- Manually typed in 'D:\FireFox' as an installation directory and proceeded
without problems.
*** Bug 276540 has been marked as a duplicate of this bug. ***
Blocks: 282239
No longer blocks: 282239
Blocks: 282239
Flags: blocking-aviary1.1?
Blocks: 283676
No longer blocks: 283676
implementing a custom filepicker for the sake of NT4 and Win98 first edition
isn't going to happen.  Needs mention in the release notes though.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Keywords: relnote
Should this then be marked as WONTFIX?
(In reply to comment #20)
> implementing a custom filepicker for the sake of NT4 and Win98 first edition
> isn't going to happen.  Needs mention in the release notes though.

I'm afraid this definitely affects Win98 second edition also. I wouldn't be
surprised if there are actually more Win98 users than Linux users.

All that would be needed is an little wrapping of the BrowseForFolder dialog, I
think.
Flags: blocking-aviary2.0?
Assignee: bugs → nobody
QA Contact: bugzilla → installer
There's another bug on allowing manual entry of install path, but this isn't really fixable properly.
Status: NEW → RESOLVED
Closed: 16 years ago
Flags: blocking-aviary2? → blocking-aviary2-
Resolution: --- → WONTFIX
*** Bug 233746 has been marked as a duplicate of this bug. ***
(In reply to comment #23)
> There's another bug on allowing manual entry of install path, but this isn't
> really fixable properly.

1) Any chance of pointing us at the other bug so I can at least vote for that?
2) Is there a separate bug on the fact that this is still not mentioned in the Release Notes?
3) Is this installer basically a 7-Zip one, and if so, would it be worth me submitting a bug to their developer instead?
4) Did the 'we nuke everything in the directory you put Firefox in' bug get fixed? If not, the combination of this one and this one will still be a problem.
For anyone seeing this problem on Win98, can you please let us know what you think a good release note for this bug should be?
(In reply to comment #26)
> For anyone seeing this problem on Win98, can you please let us know what you
> think a good release note for this bug should be?

Something along the lines of "When choosing the 'Custom' setup option on these platforms, it will not be possible to create a new directory to install Firefox into. The workaround for this is to create the required directory before running the installer, and to then navigate to that from the Browse window when prompted during installation."
Jay (or anyone): was it decided to leave this out of the release notes, or was it just forgotten? could it be added?
Michael:  I think Rafael decided to leave this out of the 1.5 release notes because we already had a large list of relnotes to include.  Not sure if he plans to make a note of this workaround anywhere else...Rafael?
> 1) Any chance of pointing us at the other bug so I can at least vote for that?
Bug 229343, which has been marked as a duplicate to this bug.

I suppose this is cheerfully irrelevant now that Bug 330276 dropped support for Windows 98/NT4.
(In reply to comment #30)
> I suppose this is cheerfully irrelevant now that Bug 330276 dropped support for
> Windows 98/NT4.

No, because that bug applies to the trunk/FF3. We still have branch/FF2 with plenty of Win98 users.
See Also: → 385333
You need to log in before you can comment on or make changes to this bug.