M17rc1 Crash while importing address book from OL 2000 - [@ nsOutlookMail::CreateList]

VERIFIED FIXED

Status

MailNews Core
Import
--
critical
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Tom Maddox, Assigned: Bienvenu)

Tracking

({crash, topcrash, verified1.7})

Trunk
x86
Windows 2000
crash, topcrash, verified1.7

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

When I attempt to import the address book from Outlook 2000, Mozilla crashes.  

Reproducible: Always

Steps to Reproduce:
1. In Mozilla Mail, go to Tools->Import->Address Books.
2. Select Outlook.
3. Crash.

Actual Results:  
Windows reports that the application has crashed and creates a logfile of the
crash report.

Expected Results:  
Imported the address book from Outlook.

This is on Windows 2000 SP4 with latest critical updates, Office 2000 SR3 with
latest updates.  Using the Pinball theme in Mozilla.

Updated

15 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

15 years ago
Created attachment 137967 [details]
Doctor Watson logfile

The most recent log file from Dr. Watson after this crash.
(Assignee)

Comment 2

15 years ago
does this happen with every outlook address book, or just yours? I don't have
outlook 2000, so I can't try this. What if you make a simple address book with
just one entry, and try to import it? If that also crashes, perhaps you could
attach that address book...
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
When you tell Mozilla to import an address book from Outlook, what file(s) does
it look at?  Is it looking at the outlook.pst file or some other file?
(Assignee)

Comment 4

15 years ago
I don't know, actually. I seem to remember that Outlook does stick everything in
one giant file, so that could be it. But that would include all your e-mail
messages, everything, I think...
(Reporter)

Comment 5

15 years ago
Right, Outlook keeps its info in a file typically called outlook.pst.  There is,
however, an external Address Book application used by Outlook and Outlook
Express, and I'm curious to know if Mozilla is trying to read the PST file or
the Address Book file.  Unfortunately, I lack the knowledge to go through the
Mozilla code and figure it out myself, but perhaps I'll take a whack at it with
a debugger tomorrow.
(Assignee)

Comment 6

15 years ago
Looking at the code, it looks like we use MAPI to get the address books from
Outlook (so that means it's up to Outlook as to where the AB's come from). That
also means that Outlook must be registered as the default e-mail handler while
you're importing Outlook AB's. Is Outlook registered as the default e-mail
client? We shouldn't crash in any case, but we should also put up a descriptive
error message if Outlook isn't the default MAPI client.
(Reporter)

Comment 7

15 years ago
Outlook ought to be my default mail handler.  I switched the default to Mozilla
Mail, then opened Outlook, which caused it to prompt me to make it the default.
(Assignee)

Comment 8

15 years ago
If you can build and debug the code, then we'll know the stack trace of the
crash and it ought to be easy enough to fix.

Comment 9

14 years ago
Not sure if this is the right way to report it - but happened to me too, also
using OL2000 on a Win2k system, with OL as the default email application.

Workaround - I had Outlook Express installed too, which was set to
'share outlook addressbook', and I did an import to Mozilla from that without a
problem.

Hope this helps

Comment 10

14 years ago
I'm having the same problem with Outlook 2000 SP-3 and Win 98SE.  When trying to
import Outlook address book, it gets about 9/10 of the way finished (as reported
by the status bar, then crashes.  I successfully imported my mail files and my
IE bookmarks.  I was able to import my Outlook Express address book.

Comment 11

14 years ago
bienvenu, there are lots of reports of crashes importing from Outlook in
talkback. The stack looks like this:

nsOutlookMail::CreateList
[/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp, line 1081]
nsOutlookMail::ImportAddresses
[/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp, line 1012]
ImportOutlookAddressImpl::ImportAddressBook
[/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp, line 627]
ImportAddressThread [/mozilla/mailnews/import/src/nsImportAddressBooks.cpp, line
927]
_PR_NativeRunThread()
_PR_MD_CREATE_THREAD()
msvcrt.dll + 0x27fb8 (0x77c37fb8)
kernel32.dll + 0x1d33b (0x77e7d33b)

These crashers are reported on win98, win2k, and winXP. 

Comment 12

14 years ago
It's suggested in bug 226176 that this is specific to importing ABs with
distribution lists. 
(Assignee)

Comment 13

14 years ago
without having a copy of outlook, this is very hard  for me to recreate the
problem. I can try faking it out since it uses MAPI...
(Assignee)

Comment 14

14 years ago
it uses mapi 1.0, not mapi 0 (duh), so I can't even fake this...I really need a
copy of outlook to debug this, or help from someone who does.
Assignee: cavin → bienvenu
(Assignee)

Comment 15

14 years ago
I tried a simple case of a contact and a distribution list, and didn't have a
problem. If anyone wants to e-mail me their Outlook.pst file, I have Outlook
now, so I can try it. I think you can export your address book to a pst file, so
you don't have to send me your whole outlook data file, but just the address
book. Thx.
(Assignee)

Comment 16

14 years ago
Created attachment 147345 [details] [diff] [review]
proposed fix

I was able to recreate the crash by creating an empty distribution list - this
fixes the crash for me.
(Assignee)

Updated

14 years ago
Attachment #147345 - Flags: superreview?(mscott)

Comment 17

14 years ago
Comment on attachment 147345 [details] [diff] [review]
proposed fix

Let's take this on the 0.6 branch for tomorrow's respin if we can.
Attachment #147345 - Flags: superreview?(mscott) → superreview+

Updated

14 years ago
Blocks: 240476
(Assignee)

Comment 18

14 years ago
Comment on attachment 147345 [details] [diff] [review]
proposed fix

simple null check.
Attachment #147345 - Flags: approval1.7?
(Assignee)

Comment 19

14 years ago
fixed on trunk and tbird .6 branch
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 20

14 years ago
Comment on attachment 147345 [details] [diff] [review]
proposed fix

a=chofmann for 1.7
Attachment #147345 - Flags: approval1.7? → approval1.7+
(Assignee)

Comment 21

14 years ago
fixed 1.7
Keywords: fixed1.7

Comment 22

14 years ago
*** Bug 242002 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
Adding Talkback info from duped bug for tracking.
Keywords: topcrash
Summary: Crash while importing address book from OL 2000 → M17rc1 Crash while importing address book from OL 2000 - [@ nsOutlookMail::CreateList]

Comment 24

14 years ago
Verified as fix on the lastest Mozilla nightly 06-15 build.
Status: RESOLVED → VERIFIED
Keywords: fixed1.7 → verified1.7
QA Contact: nbaca → karenlhuang

Comment 25

14 years ago
This has been marked as verified since verification has been done for both 1.7
branch & trunk 06-15 builds
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsOutlookMail::CreateList]
You need to log in before you can comment on or make changes to this bug.