news: backtrack references

RESOLVED DUPLICATE of bug 62033

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 62033
15 years ago
11 years ago

People

(Reporter: Georg Brandl, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.5) Gecko/20031007 Firebird/0.7

it would be cool if the entries in the References header could be backtracked by
presenting them as links in the message header

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Thunderbird 1.5

This was a feature of Netscape Communicator 4.7, which I was using as my news reader until very recently.  (I have been using Mozilla Suite as my browser for a few years now.)  This is one of the Netwcape features I really miss.  

I have my preferences set for [View > Messages > All] and [View > Sort by > Order Received, Ascending, Threaded].  If I see a message in a thread where I already read the prior message in a previous session, I might want to reread that prior message.  Currently, I have to change my preferences to display the entire thread; afterwards, I then must restore my preferences.  This RFE would eliminate need to manipulate viewing preferences.  
OS: Windows XP → All
Hardware: PC → All

Comment 2

13 years ago
Also, fixing this bug would empower quoteing linking messages posted in another group and/or encorporating elements of the referenced post.

Comment 3

13 years ago
This is actually a dupe of the Suite bug 62033.

Comment 4

13 years ago
Yes, this is a duplicate of bug 62033.  However, that is a Mozilla Suite bug while this is a Thunderbird bug.  Since Mozilla Suite and Thunderbird now have somewhat different development, this bug should not be closed as a duplicate.  
QA Contact: front-end

Comment 5

11 years ago
fixed by bug 62033 on trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 62033

Comment 6

11 years ago
Bug #62033 was a Mozilla Suite (i.e., SeaMonkey) bug.  This is a Thunderbird bug.  

Bug #62033 used preference variable mailnews.headers.showReferences in its fix.  No such preference variable can be found in Thunderbird.  

Reopening so that it can be fixed in Thunderbird.  
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

11 years ago
What thunderbird version did you check for mailnews.headers.showReferences ?
The pref exists for me on thunderbird trunk version 3.0a1pre (2007081410).
a) it defaults to false, b) appears to only affect mail, not news - news displays reference links regardless of the setting, c) and afaict requires application restart to take effect

You may be mistaken in your understanding of suite and thunderbird. Yes, they are separate products, but much of the mailnews code is shared. And even for code that is not completely shared, many bugs are engineered by patch authors so that both applications get the fix.  Indeed bugs which address common issues have often been duped to the other product.

So ... if a bug exists in the current implementation in thunderbird trunk, then it is a deficiency of code done in bug 62033, which should be reopened or a new bug filed against it.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 62033
You need to log in before you can comment on or make changes to this bug.