Closed Bug 229503 Opened 19 years ago Closed 18 years ago

can't change auto-detect options in view->character encoding in view source

Categories

(Toolkit :: View Source, defect, P3)

x86
Windows 2000
defect

Tracking

()

RESOLVED FIXED
mozilla1.7.4

People

(Reporter: sekundes, Assigned: sspitzer)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

set auto-detect options in source viewer makes source disappear

Reproducible: Always

Steps to Reproduce:
1.Ctrl+U(Page Source).
2.Wait until all the source loads.
3.View->Character Coding->Auto-Detect->click anyone of them.
Actual Results:  
The page source disappears.

Expected Results:  
The page source should not disappear.
Whiteboard: DUPEME
*** Bug 229504 has been marked as a duplicate of this bug. ***
From bug 229504, this is supposedly present in FB as well.
WFM in the latest build of Mozilla now, but not Firefox.
=> Product
Component: ViewSource → General
Product: Browser → Firefox
Summary: set auto-detect options in source viewer makes source disappear → no effect on selecting auto-detect options in source viewer
Version: Trunk → unspecified
WFM.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040511
Firefox/0.8.0+
- Microsoft Windows 2000 Pro 5.00.2195 SP4
Re #4:
The page source no longer disappeared(it's old bug report) but the Auto-detect
option could not be changed via the menu from page source viewer.

I still experienced this bug using Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.8a) Gecko/20040513 Firefox/0.8.0+
Keywords: useless-UI
Confirming using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040610 Firefox/0.8.0+ (Steffen). WFM with Mozilla 1.7 RC2.
-> view source.

The js console shows:
Error: BrowserSetForcedDetector is not defined
Source File: chrome://global/content/charsetOverlay.js
Line: 118
Assignee: doronr → bugs
Status: UNCONFIRMED → NEW
Component: General → View Source
Ever confirmed: true
Keywords: useless-UI
QA Contact: firefox.view-source
Summary: no effect on selecting auto-detect options in source viewer → can't change auto-detect options in view->character encoding
Whiteboard: DUPEME
Flags: blocking1.0?
This is obscure, but broken UI sucks in a finished product. Also, the patch
should be really easy. Putting on the 1.0 list for now.
Flags: blocking1.0? → blocking1.0+
Priority: -- → P3
Target Milestone: --- → Firefox1.0beta
Flags: blocking-aviary1.0RC1+
Assignee: bugs → sspitzer
accepting...working on it.
Status: NEW → ASSIGNED
Summary: can't change auto-detect options in view->character encoding → can't change auto-detect options in view->character encoding in view source
fixed on both firefox trunk and firefox aviary 1.0 branch.

note on the trunk, due to #250474, the fix is slightly different:

-  // As with BrowserSetForcedCharacterSet(), call PageLoader.LoadPage()
+  // As with BrowserSetForcedCharacterSet(), call PageLoader.loadPage()

-  PageLoader.LoadPage(PageLoader.currentDescriptor,
pageLoaderIface.DISPLAY_NORMAL);
+  PageLoader.loadPage(PageLoader.currentDescriptor,
pageLoaderIface.DISPLAY_NORMAL);
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
setting fixed-aviary1.0 for bugfixes checked into branch, sorry for bugspam.
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.