Last Comment Bug 229547 - "Save all files to this folder" doesn't apply to "Save Image as..."
: "Save all files to this folder" doesn't apply to "Save Image as..."
Status: VERIFIED WONTFIX
:
Product: Toolkit
Classification: Components
Component: Downloads API (show other bugs)
: unspecified
: All All
: -- enhancement with 12 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :Paolo Amadini
Mentors:
Depends on: 394910
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-27 17:49 PST by Aaron Read
Modified: 2009-08-11 05:46 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Aaron Read 2003-12-27 17:49:03 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031215 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031215 Firebird/0.7

The "Save files to fhis folder" feature seems to only work for "Save link To
disk". It would be cool if this feature also worked for "Save image as..."

Reproducible: Always

Steps to Reproduce:
1. Find an image you wish to steal
2. Select "Save image as..."
3. Click on "Save" in "Save as" dialog box
4. Goto 1

Actual Results:  
Save as dialog box takes a long time to load, especially when the default is
selected each time.

Expected Results:  
Eliminate step 3.

Firebird enhances my user experience daily. Keep up the good work.
Comment 1 willyang 2004-01-18 03:03:46 PST
i encounter this trouble when i want to save *.exe or *.pdf. 
Comment 2 Jesse Ruderman 2004-01-18 04:04:06 PST
yangmiao@softhome.net: that sounds unlikely, considering that *.exe and *.pdf
are not images.
Comment 3 Jesse Ruderman 2004-01-18 04:05:25 PST
yangmiao@softhome.net: since your problem isn't this bug, you should keep
searching or file a new bug.
Comment 4 Scott McIntyre 2004-04-20 15:35:48 PDT
It's inconsistent that saved images are listed in the download manager, but
aren't affected by the download options which explicitly refer to "all files".
Comment 5 Jesse Ruderman 2004-04-22 00:48:34 PDT
See also bug 232702, *opposite* bug for "Save Link As...".
Comment 6 Ali Ebrahim 2004-04-30 14:47:35 PDT
taking qa
Comment 7 Jesse Ruderman 2004-06-29 09:59:28 PDT
"Save Link As..." was recently changed to have the same behavior as "Save Image
As..." :(  See bug 244961.
Comment 8 Noemi 2004-06-29 20:29:46 PDT
I really appreciate the fact that FF makes it easy to download images to a
different folder than the default download folder.  

I'm frequently working on projects in vastly different places in my filesystem,
and will want to save a dozen images in a row to one place, and then another
dozen to another, neither of which is ever anywhere near the downloads folder I
use as a depository for all installers and archives (for instance, the
self-starting downloads from Sourceforge, which don't give an option to download
to another location).  

Anyhow, if this change is made, can there be a preference to revert to the
original behavior?
Comment 9 Michael Moulton 2005-04-14 07:18:31 PDT
I would love this feature to return.
Additionally, the Save Image As... (or Ctrl-S / Apple-S on an image) works
sporadically since this change was first made.  It always worked fine when the
files were automaticall saved, but since this change I often get no dialog when
trying to save an image, until I try a few times.
Comment 10 Shawn Wilsher :sdwilsh 2007-11-12 08:50:00 PST
This change was in fact intentional.  WONTFIX

Note You need to log in before you can comment on or make changes to this bug.