trailing "../" on ftp address bar

RESOLVED WONTFIX

Status

()

Core
Networking: FTP
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: iwan m rubiawan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

I thought i've found a bug on mozilla.
I was using mozilla 1.6 win32. It also
occur on mozilla firebird.
When you use ftp to browse an ftp site then
click "Up to higher level directory" link.
the "../" trail keep adding in.

After several times you click, then you 
return to enter one link, the trailing "../"
still there.

I hope somebody will fix it.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 138050 [details]
trailing "../"
(Reporter)

Comment 2

14 years ago
Created attachment 138051 [details]
trailing "../" still there

Updated

14 years ago
Assignee: dougt → darin

Comment 3

14 years ago
-> NEW.
This sounds real, possibly related to the fix for bug 207298.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Please give more specific steps (I start in this URL, I click this URL, I see
that URL displayed, and it is wrong... etc.

Comment 5

14 years ago
Yes, this is the case, but it should not get you into any trouble, you should be
able to view any file traversing the tree even with additional ..

This is deliberate and was as trade to fix a real bug, not something that only
looks ugly. See bug #207298 for details and reasoning.

Comment 6

14 years ago
*** Bug 244256 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
it seems that these URLs work, but bug 244256 pointed out they don't work in
other browsers.

Is this a valid URL, syntax-wise?

Comment 8

12 years ago
-> default owner
Assignee: darin → nobody
QA Contact: benc → networking.ftp

Comment 9

9 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090411 Minefield/3.6a1pre it happens in the root directory (for example <ftp://ftp.mozilla.org/>), but also in directories with a leading dot (for example <ftp://ftp.support.acer-euro.com/.netbook/>).
only critical ftp fixes at this point
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.