Popup Window is not resizable

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Bryan Batten, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

The popup window that appears after going to the indicated URL and clicking on
the  picture titled "Ellen and friends fitting the mast" is not resizable -
scrollable, yes, but not resizable. Resizing works fine when the Windows XP
version is used.

Reproducible: Always

Steps to Reproduce:
See Details.



Browser Mozilla 1.5
Kernel Linux 2.4.23
X Server XFree86 4.1.0-16woody1 (Debian)
Window Manager fvwm 2.4.6-2 (Debian)

Comment 1

14 years ago
WFM RH9, 1.6b.

The javascript seems to be explicitly allowing resizing...

Can you try with a new profile? And a nightly build if possible?
It's not resizable on Win98 either.  I suspect the problem is that turning off
the status bar makes us not show the resizer on the bottom right; if that's the
only way the window is resizable...

Or are you seeing something else on Linux?

Comment 3

14 years ago
Basically Mozilla (and IE) do what the page says; line 176 makes no mention of
resizability so we default to off... code is: winprops =
'height='+h+',width='+w+',top='+wint+',left='+winl+',toolbar='+tool+',status='+status+',scrollbars='+scroll+''
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Oh, interesting.  There are two places on that page that define function
NewWindow; the first adds resizable=yes to the flags, the second does not.  The
second one wins, of course.
You need to log in before you can comment on or make changes to this bug.