Closed Bug 22968 Opened 20 years ago Closed 20 years ago

Exit with Gtk warning in commercial build

Categories

(Core :: XUL, defect, P1, critical)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: slogan, Assigned: slogan)

Details

Steps to reproduce:

Start mozilla on a slow connection (e.g., 56K modem) or with home page set to
something that will take a while to load.
Login to IM using the BuddyList panel in the sidebar.

WEBSHELL- = 4
00:00:26: Socket 08616770: Got FD_CONNECT
00:00:26: Socket 08616770: Got FD_WRITE

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkObject'
warning: attempted to CreateNative() without a superwin parent

and then you exit.

If you stop loading the page, or wait for it to load then login, no problem
occurs.
Is this something that only happens with IM?  If that's the case I probably
won't be able to find it.
Severity: major → critical
Priority: P3 → P1
If that's the case then reassign to pavlov, or work with me to fix it. It is
unacceptable that superwin just exits like this.
It doesn't exit.  It probably segfaults somewhere.
seeing how IM crashes my browser on startup, I think it will be hard for me to
debug this.
Assignee: blizzard → syd
As per syd's comment below I'm assigning it to him since it's triggered by IM.
Target Milestone: M15
Moving Syd's non-PDT+ bugs to M15 to indicate that he will not have time to get
to them for Beta.
I haven't seen this in a long while. Marking works for me.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Sorry for the spam, changing QA contact.
QA Contact: paulmac → jrgm
You need to log in before you can comment on or make changes to this bug.