Use distinct file extensions for pre-processed content, so they can be validated during compile time

RESOLVED WONTFIX

Status

()

Firefox
Build Config
--
enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Part of the discussion in Bug 229639 revolved around distinguishing content
which is pre-processed (XBL, XUL, XHTML, JS, CSS) from "normal" content by using
a distinct file extension such as .pre-xml, etc.

This would help distinguish content which can be checked for well-formed-ness
and potentially for validity from content which requires separate pre-processing
before it should be checked. As part of this bug it should be possible to hook
in validating checks to ensure that both the "normal" content and the output of
the pre-processed content is valid.
Also, we can validate CSS already -- dbaron wrote an app that does so.  I
believe we don't do it because there are quite many CSS errors in chrome and no
one has managed to get a patch to fix them up reviewed... (but maybe I'm wrong?
 Then we should hook this up as a tbox test).
I agree 100% with bz in bug 229639 comment 16.
Summary: Use distinct file extensions for pre-processed content → Use distinct file extensions for pre-processed content, so they can be validated during compile time
Bug 139942 is the bug for the CSS errors, though the patch in it is quite old.
There's many of them and iirc the problem is mostly finding out the right fix
for each one.
Assignee: bryner → nobody
QA Contact: asa → build.config
Version: unspecified → Trunk
This seems like jumping through hoops.  We should just check everything after its built, rather than some before, and some after.  Were we to do such a thing, rather than just writing unit tests for the functionality and having well-formedness errors blow those tests up.

Either way, this is not worth the trouble, IMO.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.