Conflict with WindowsXpgtk themes

RESOLVED WORKSFORME

Status

()

Firefox
Build Config
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: wbtxuan, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: 

I download the source code of MozillaFirebird(ver 0.7).I compiled it by static 
method.
But the Firebird crash with WindowsXpgtk themes.

The contents of the .mozconfig are as follows:
 export MOZ_PHOENIX=1
 mk_add_options MOZ_PHOENIX=1
 ac_add_options --disable-xprint
 ac_add_options --disable-composer
 ac_add_options --disable-debug
 ac_add_options --disable-ldap 
 ac_add_options --disable-mailnews 
 ac_add_options --disable-tests
 ac_add_options --disable-gtktest
 ac_add_options --enable-necko-protocols=http,res,jar,ftp,file
 ac_add_options --enable-crypto 
 ac_add_options --enable-strip 
 ac_add_options --enable-strip-libs 
 ac_add_options --enable-extensions=cookie,xml-
rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices
 ac_add_options --enable-static 
 ac_add_options --disable-shared 
 ac_add_options --enable-optimize
 However,if I disable the the static method,Firebird startup normallly!

Reproducible: Always

Steps to Reproduce:
1.Modify .mozconfig
2.configure
3.make
4.mke install

Actual Results:  
Firebird cannot statup!

Expected Results:  
Resolve this bug!

Comment 1

15 years ago
Try removing linux only options like :

ac_add_options --disable-xprint
ac_add_options --disable-gtktest
ac_add_options --enable-strip 
ac_add_options --enable-strip-libs 

Also, can you try this .mozconfig instead (it is working for me without any
problem for weeks)

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1

ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options
--enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices
ac_add_options --enable-crypto
ac_add_options --disable-composer
ac_add_options --disable-profilesharing
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-shared
ac_add_options --enable-static
ac_add_options --enable-optimize

What is you compiler ? Mine is Visual C++ 6.0 SP5 (official one following
mozilla.org build instructions)

Comment 2

14 years ago
Should this bug be in the Linux OS? Reporter, you're using Windows?

Anyway, is this still an issue? Been quite some time, please close if you can no
longer get this error.
No answer for more than a month since last comment, so closing as WFM.

Reporter, please reopen if you think this bug is still valid.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.