If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Selection of Dutch language showstopper for non-root

VERIFIED INVALID

Status

()

Core
Internationalization
VERIFIED INVALID
14 years ago
10 years ago

People

(Reporter: Ernst de Haan, Assigned: smontagu)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; FreeBSD)
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5) Gecko/20031227

I installed the Dutch language pack on my FreeBSD 4.9-STABLE box as root. I 
answered the question 'Install for all users' with a 'Yes'. 
 
Now when I select the Dutch language on 'Language and Content Packs', and 
restart Mozilla, it shows something illegible. 

Reproducible: Always

Steps to Reproduce:
1. Have a FreeBSD 4.x box 
2. Install Mozilla from ports (/usr/ports/www/mozilla) 
3. Start X as root 
4. Install the Dutch (NL) language pack from http://www.mozilla.org/projects/
l10n/mlp_status.html#contrib 
5. Agree to have the language pack installed 
6. Agree to have the language pack installed globally, so all users can use it 
7. Start X as a non-root user 
8. Delete the ~/.mozilla directory for that user (if it exists) 
9. Go to Edit -> Preferences -> Appearance -> Languages/Co... 
10. Select the language pack 'Nederlands (NL)' 
11. Click OK 
12. Quit Mozilla 
13. Start Mozilla 
Actual Results:  
See the JPEG image. 

Expected Results:  
Start up. 

My uname -a: 
 
FreeBSD blacky.lan 4.9-STABLE FreeBSD 4.9-STABLE #8: Mon Dec 29 06:18:46 GMT 
2003     root@blacky.lan:/usr/obj/usr/src/sys/BLACKY  i386 
 
Dual Pentium III (450 MHz) (SMP kernel)
Sounds like the "for all users" part didn't work....
(Reporter)

Comment 2

14 years ago
When compiling Mozilla, I only compiled the browser, not Mail/News, not
Composer, not Chatzilla and not the XML Terminal.

Settings I passed to the port for this were:

WITHOUT_MAILNEWS=YES
WITHOUT_COMPOSER=YES
WITHOUT_CHATZILLA=YES
WITHOUT_XMLTERM=YES
(Reporter)

Comment 3

14 years ago
Created attachment 138274 [details]
The preferences file with the locale set.

This is my prefs.js file right after I did the following:
1. Remove directory ~/.mozilla
2. Startup Mozilla
3. Select the Dutch language
4. Exit Mozilla
(Reporter)

Comment 4

14 years ago
Here are the MD5 checksums of the language pack files: 
 
# find /usr/X11R6/lib/mozilla/ | grep NL | xargs /sbin/md5 
MD5 (/usr/X11R6/lib/mozilla/chrome/nl-NL.jar) = 
664d065dc145fedf5a4943999df7ffd6 
MD5 (/usr/X11R6/lib/mozilla/chrome/NL.jar) = 99b36e53dec12fb254777c39fb2f477d 
(Reporter)

Comment 5

14 years ago
And some more MD5s: 
 
# find /usr/X11R6/lib/mozilla/ | grep '[^w]nl' | xargs /sbin/md5 
MD5 (/usr/X11R6/lib/mozilla/chrome/nl-win.jar) = 
db9e52e684e3e365bddc1f27bbd3727a 
MD5 (/usr/X11R6/lib/mozilla/chrome/nl-mac.jar) = 
3250271b6bc59b5723a6b3c886e80a52 
MD5 (/usr/X11R6/lib/mozilla/chrome/nl-unix.jar) = 
8447d5f921e23196f86a72ed05d22d89 
MD5 (/usr/X11R6/lib/mozilla/chrome/nl-NL.jar) = 
664d065dc145fedf5a4943999df7ffd6 
I think that this bug can be closed.
as far as i can see is this fixed a long time ago, if not feel free to reopen the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

10 years ago
It's OK to close it. I have no idea what this was about, anymore :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.