Contact List loses email addresses when the list is modified

RESOLVED DUPLICATE of bug 117846

Status

--
critical
RESOLVED DUPLICATE of bug 117846
15 years ago
15 years ago

People

(Reporter: reconway, Assigned: sspitzer)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

After you have created a contact list / distribution list in the address book,
if you open the list to add or remove contacts from the list, the new contacts
are added properly, but every other contact in the list is corrupted.  The last
names remain in the list, but all other data disappears, including the email
addresses.

Reproducible: Always

Steps to Reproduce:
1. Create an address list
2. Click Ok to save it
3. Double click on the list to open the list for editing
4. Add another email address
5. Click Ok to save


Actual Results:  
All the user data in the list has now disappeared for the original list addressees.

Expected Results:  
The original list addressees should have been maintained properly and the new
contacts added to the list.

Note: You can successfully add a new contact to a list by doing the following:

1) filter the contact list or scroll until you can see the contact you want to add.
2) DO NOT open the list for editing!!!!
3) Drag the desired contact from the right pane to the contact list and drop it
onto the list.

Updated

15 years ago
Severity: normal → critical
Keywords: dataloss

Comment 1

15 years ago
Reporter, can you comment on whether the corrupted contacts contained any commas
in their Display Names?  See bug 117846 comment 9 and bug 232315.

Comment 2

15 years ago
nonresponse.  Symptoms are similar enough that it's most likely a dupe.

*** This bug has been marked as a duplicate of 117846 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.