Closed Bug 229834 Opened 17 years ago Closed 17 years ago

association when setting mozilla as default browser

Categories

(SeaMonkey :: UI Design, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 131106

People

(Reporter: mark, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031231
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031231

When I install/reinstall/upgrade Mozilla and answer Yes to the dialog asking me
if I want to set mozilla as my default browser, mozilla takes over all
associations and replaces icons to the associations with its own icon.
This is irritating and confusing:
* My PNG files aren't opened with Adobe ImageReady CS anymore but with a browser
* Icons are replaced so I cannot see the difference between PNG, HTML and JPEG
without looking to the extension/file properties
* My desktop is red of dragons

Reproducible: Always

Steps to Reproduce:
1. Install/reinstall/upgrade Mozilla.
2. Answer Yes to the dialog asking you if you want to set mozilla as your
default browser.

Actual Results:  
PNG/JPEG/HTML file associations got changed to mozilla and had their icons
changed. Sometimes it only changes the icons for the image

Expected Results:  
NOT associate image file types, not replace icons for images and have a better
HTML icon ;).
Default browser doesn't mean it should associate to filetypes other than HTML.

*** This bug has been marked as a duplicate of 131106 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.