Selecting <b> node with double-click erroneously extend to include next word

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: mbougon, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040101
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040101

Self-explanatory Example of two errors in Composer --

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head></head>
<body marginwidth="66">Line One<br>
<ul>
  <li>Error One -- When unbolding this <b>WORD</b> a blank line will be inserted
below, in error.... <br>
.<br>
Line 2 -- (The above effect can be toggled on/off by clicking on the "<b>B</b>"
button)<br>
.<br>
Line 3 --&nbsp; (The above error occurs when the text fits on a <i><b>single
</b></i>line)<br>
.</li>
  <li>Error Two --&nbsp; When doubleclicking on this <b>WORD </b>when it is
bolded the selection (hili) will extend past the following "when",&nbsp; in
error.......<br>
.<br>
Line 22<br>
.</li>
  <li>Indent Three --<br>
.<br>
    <br>
  </li>
</ul>
&nbsp;
</body></html>


Reproducible: Always

Steps to Reproduce:
1. Load the example in Composer (as html source)
2. Follow the instructions in the text of the example
3.

Actual Results:  
Actual results are described in the text of the example.

Expected Results:  
1.  No erroneous insertion of an extraneous blank line
2.  No selection (hili) erroneously extending and including the next word

Comment 1

14 years ago
Thanks for trying to do a testcase. Next time, just upload it in attachment
instead of pasting the code.
General rule in bugzilla is to report distinct, separate bugs into single,
separate, distinct bug reports.

I can not reproduce the insertion of an extraneous blank line.
Mozilla 1.8a5 build 2004100504 under XP Pro SP2 here.

Regarding the double-click to select a node, I get the results you get (the
following "when" word is also selected, highlighted).

If the code is
this <b>WORD </b>when ..., then I get the actual results but 
if the code is
this <b>WORD</b> when ..., then I get the expected results.

The correct way to code is to delimit only the text node like this: 
this <b>WORD</b> when

I still need to verify if there are any duplicate of the bug.
Summary: Two Errors involving Bolding and Selecting → Selecting <b> node with double-click erroneously extend to include next word

Comment 2

14 years ago
This bug is related somehow to bug 248860; it involves better word selection
when considering the markup code as well.
Whiteboard: somehow related to bug 248860

Comment 3

14 years ago
Fixed by the patch in bug 256252
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Depends on: 256252
Resolution: --- → FIXED
Whiteboard: somehow related to bug 248860
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.