frequent crash hitting back button

VERIFIED DUPLICATE of bug 18798

Status

()

Core
Layout
P3
blocker
VERIFIED DUPLICATE of bug 18798
18 years ago
18 years ago

People

(Reporter: buster, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I see this crash often.

Open a site
Surf to another page (same site or different)
Then another page
Hit back button twice, the second time while the first "back" url is still
loading.

Crash!

RestoreFrameStateFor(nsIPresContext * 0x0322b8c0, nsIFrame * 0x020b04a8,
nsILayoutHistoryState * 0x0306e3f0) line 1450 + 21 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x020b04a8, nsILayoutHistoryState * 0x0306e3f0) line
1468 + 17 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02126420, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02a89798, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x021264a4, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02bcb6c0, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x00df7fd0, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02a898b4, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x020b0460, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x020b03bc, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x020b027c, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f47c, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f708, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f69c, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f64c, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f3d8, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x020b0404, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02b7f7ec, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x031d8bb0, nsIPresContext
* 0x0322b8c0, nsIFrame * 0x02a89710, nsILayoutHistoryState * 0x0306e3f0) line
1477 + 24 bytes
PresShell::ContentAppended(PresShell * const 0x031de148, nsIDocument *
0x0322db50, nsIContent * 0x032489ec, int 3) line 2410
nsDocument::ContentAppended(nsDocument * const 0x0322db50, nsIContent *
0x032489ec, int 3) line 1545
nsHTMLDocument::ContentAppended(nsHTMLDocument * const 0x0322db50, nsIContent *
0x032489ec, int 3) line 1112
HTMLContentSink::NotifyAppend(nsIContent * 0x032489ec, int 3) line 3722
SinkContext::FlushTags() line 1805
SinkContext::DidAddContent(nsIContent * 0x0349a7fc, int 0) line 1129
SinkContext::FlushText(int * 0x00000000, int 0) line 1897
SinkContext::FlushTags() line 1751
HTMLContentSink::Notify(nsITimer * 0x0347e530) line 2197
TimerImpl::Fire(unsigned long 696422853) line 317
TimerImpl::ProcessTimeouts(unsigned long 696422853) line 191
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 26392, unsigned
long 696422853) line 105 + 9 bytes
USER32! 77e7128c()
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
*** This bug has been marked as a duplicate of 18798 ***

Comment 2

18 years ago
Marking verified dup of 18798.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.