"Small Cyrillic Letter I" truncated when saved in CalendarDataFile.ics, if it is a last character of Title

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Vangel Ajanovski, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

If you write a cyrillic string in Title or Note of an Event, and this string
ends with the "Small Cyrillic Letter I" - that is UTF-8 0xD0B8, everything will
seem fine until you restart Thunderbird and Calendar. After that, the Title and
Note field show only ??????????.

This is true for creating new events, for editing old events that worked OK, and
also for importing events. So it is probably a problem with the routine for
saving the event data into the CalendarDataFile.ics. If fact if you open this
file you will see that the text is generally OK, except that is misses the last
byte - 0xB8. 

This problem does not occur if the character 0xD0B8 is somewhere in the middle
of the text string in title.


Reproducible: Always

Steps to Reproduce:
1. Create an event having title in any characters, ending with "Small Cyrillic
Letter I".
2. Close Calendar.
3. Close Thunderbird.
4. Open Thunderbird.
5. Open Calendar.
Actual Results:  
1.The event looks like ??????????? for all its cyrillic characters. Latin
characters show OK.
2.The title of the event in the CalendarDataFile.ics misses the last byte 0xB8
from the "Small Cyrillic Letter I" and ends with 0xD0 only.

Expected Results:  
1.It should have written the right characters.
2. The title of the event in the CalendarDataFile.ics should end with 0xD0B8

The problem is very important for many people using cyrillic because the "Small
Cyrillic Letter I" at the end of the word is used to indicate plural, hence very
often is almost impossible to work with Calendar. 

I did not find a fix, but if you put a dot "." on the end of the string, the
string will show ok. So this is a workarround, but is not very nice.

Unfortunately this can not be done when importing events from a file.
works for me on a current cvs build.
Is this still a problem with recent builds for you? (i can't really test, since
i don't write cyrillic)
(Reporter)

Comment 2

14 years ago
I never got any notice about that being fixed, but it was fixed in the last
version of Sunbird. I can say that only on the letter "Small Cyrillic Letter I",
but I think I got similar problems with few other letters. At this moment my
computer is kinda in the middle of installation and I don't have Thunderbird
with Calendar nor Sunbird on it, but as soon as I have I will try and find out
about all the other letters.

Is it better to submit another bug for the other letters and mark this one as
resolved, or write the new information here?
Just add new information here. If it is different enough, we can always open a
new bug.
(Reporter)

Comment 4

14 years ago
Seems that this is fixed in the version of SunBird for Windows 7.9.2004
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.