Unable to get length and value of Radio buttons

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: brian, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

I have seen this problem on a number of web pages; I created my own page which
demonstrates the problem.  Selecting an option using the above link
(http://test.voodoochild.org/ww.html) in Mozilla 1.5 on Windows XP produces
messages which say that the length of the radio buttons is "undefined" (I would
expect "4") and that no option is selected (I would expect whichever one is
selected).  I don't believe this to be a problem with the JS code because I have
tested this page using Mozilla 1.4 and IE 6 and both work as I would expect. 
This suggests some kind of issue with the JS Engine or the DOM in 1.5.  Was able
to reproduce on two different XP machines running Mozilla 1.5.

Reproducible: Always

Steps to Reproduce:
See above
Actual Results:  
See above

Expected Results:  
See above

Comment 1

15 years ago
could you please try with an updated build?
the test is WFM with build 2003121608 and XP
(Reporter)

Comment 2

15 years ago
Upgrading to the latest build works as expected.  Any idea why this problem
exists in 1.5 but not 1.4 nor the latest build?  Just curious..In any event, thanks.

Comment 3

15 years ago
If this is working for you mark it as WORKFORME thanks.  I did a quick search
and couldn't find what bug fixed this problem.
(Reporter)

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.