special character in a a tags href link when making a link to an email is not parsed right to the mail client.

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: rbb, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Clicking the following link gets a strange subject in the email that do not
match the subject in the link. The special characters is not parsted right to
the email subject.
<a href="mailto:rbb@it-jobbank.dk?subject=test of special
charatersæøåÆØÅÜ">rbb@it-jobbbank.dk</A>
The error is tested with woth outlook (2002) and mozillas email client.
The error do not occure on mozilla 1.4.

Reproducible: Always

Steps to Reproduce:
1. Click the link in the detail description.

Actual Results:  
the email have the following subject : "test of special charatersæøåÆØÅÜ"

Expected Results:  
the email should have had the following subject: "test of special charatersæøåÆØÅÜ"
this is working for me on a 0.8 branch build w/Thunderbird.  Please get a
current 0.8 nightly and retest this.
QA Contact: mconnor
(Reporter)

Comment 2

15 years ago
This do not work with Outlook 2002 or Mozilla 1.4's email client
(Reporter)

Comment 3

15 years ago
Clarification: The bug is found using using Outlook 2002 and the email client in
Mozilla 1.4.

Comment 4

15 years ago
(In reply to comment #1)
> this is working for me on a 0.8 branch build w/Thunderbird.  Please get a
> current 0.8 nightly and retest this.

It seems that internally Firebird converts all diacritical (maybe some other
too) characters within any (including mailto) links to UTF-8.
The problem is, that in case of external programs, the URI's are passed on to
the external program in UTF-8 also.
Thunderbird apparently can handle UTF-8 encoded URI's, but Outlook can not.
Firebird nightly 0.8 behaves similarily.

Comment 5

15 years ago
I get no error when using 0.9 built with firefox

Comment 6

15 years ago
Build is too old to be of use.  Please try to reproduce this bug on FF 0.9 or a
nightly.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 7

15 years ago
Created attachment 151582 [details]
Screenshot of bug

The problem still exists in Firefox 0.9. Please see attached.
You need to log in before you can comment on or make changes to this bug.