text can not be inputted into a text input form like textarea when a java applet is loaded on the same page

RESOLVED DUPLICATE of bug 211630

Status

RESOLVED DUPLICATE of bug 211630
15 years ago
8 years ago

People

(Reporter: tba9h, Unassigned)

Tracking

({helpwanted})

Trunk
PowerPC
Mac OS X
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

In any situation involving a text input form(like textarea or input) and a
loaded and clicked on(or gains focus in another way) java applet, you cannot
switch the focus back to a text form(like textarea, etc) by any method I can
find(tried clicking, tabbing, etc). So whenever one tries to type text into the
input area, either nothing happens or the text is entered into the java applet.
Also, the blinking cursor appears in both the text input form and the applet.  

Reproducible: Always

Steps to Reproduce:
1. Open a webpage that has a java applet and text input forms. 
2. Click on Java Applet then Click back to text input form.
3. Try to input text into text input form. 

Actual Results:  
No text was entered, or text appears in the java applet

Expected Results:  
Text should have appeared in text input form.

This bug occurs in both Mozilla and Firebird on the Macintosh, but does not
occur in the Windows versions.
Sounds like a bug in the Apple Java Plugin implementation to me....
Assignee: ashuk → kyle.yuan
Component: Java APIs for DOM → Java: OJI
Summary: text can not be inputted into a text input form like textarea when a java applet is loaded on the same page → text can not be inputted into a text input form like textarea when a java applet is loaded on the same page

Updated

15 years ago
Keywords: helpwanted

Updated

15 years ago
Assignee: kyle.yuan → nobody

Comment 2

15 years ago
I'm seeing this as well. This bug is specific to Mozilla-based browsers,
including Netscape 7.1, and does not occur in other browsers that use Apple's
Java plug-in.

Comment 3

15 years ago
I believe this is a dupe of 211630.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 211630 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.