Allow multiple handlers linked to multiple filename extensions for the same MIME type

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
15 years ago
2 years ago

People

(Reporter: hacksoncode, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+

As suggestion in bug 67940 comment 59, I'm entering this new RFE to allow
multiple handlers for a MIME type based on filename extension.

The specific problem that this would address is the handling of
application/octet-stream. Bug 67940 suggests trying to figure out the file type
from the extension. It is resolved WONTFIX because Moz is handling this type
according to specifications (such as they are :-). However, it's a big and real
problem for users, because numerous boneheaded mail clients, web servers,
authoring packages, etc., continue to mistakenly (or lazily) assign this MIME
type to inappropriate files. 

There might not be a good (or at least acceptably standards compliant) solution
to this problem, but there is at least a way we could enable power users to dig
themselves out of it:  Allow adding multiple handlers for the same MIME type,
but with different filename extensions. Currently, only 1 handler can be
assigned, which leads to nonsense like .exe files all being saved as .txt files
because someone associated a plaintext application/octet-stream file to be
handled by Notepad at some point in the past. 

If the user were allowed to add additional handlers for the same MIME type, but
with different filename extensions, then saving and opening of files could be
customized by the user to work properly for them. This has different UI
ramifications for the Moz suite than for Firebird, but in both cases I think
it's a simple generalization (i.e. allowing something that's currently blocked). 

For example, allow opening appliction/octet-stream files with extension .bmp
with a paint program, but saving application/octet-stream files with extension
.exe to disk. 

Reproducible: Always

Steps to Reproduce:
>because someone associated a plaintext application/octet-stream file to be
>handled by Notepad at some point in the past. 

in current builds, that takes real effort...

What should happen if none of the entries matches? Should one of those be used?

of course there's also the problem that mimeTypes.rdf format needs to change, to
not use the mimetype as a key

confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: file-handling → nobody
QA Contact: ian → file-handling
(Reporter)

Comment 2

4 years ago
I'm guessing this won't ever be done, given the time since reporting. Sorry if marking it WONTFIX isn't the correct resolution...
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.