Poor rendering of "file input" element on a coloured background when width set

RESOLVED DUPLICATE of bug 52500

Status

()

--
trivial
RESOLVED DUPLICATE of bug 52500
15 years ago
15 years ago

People

(Reporter: andrew, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Reference: http://howsfamily.net/demo.html

The <INPUT Type="file"> element on this page should be displayed as a single,
long  text input field, with a browse button at the end. When "width:100%;" is
set in the Style attribute, however, the result is a normal-sized text input
field, the browse button, and then a white bar occupying the rest of the area.
This is most notable on a non-white background colour.

Reproducible: Always

Steps to Reproduce:
1. Include style="width:100%" attribute in a <INPUT Type="file"> tag
2. Visit website

Actual Results:  
<INPUT Type="file"> element is rendered incorrectly; a short text field, a
submit button, then a white bar.

Expected Results:  
Display a long text field, then a submit button.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.