Mozilla crashes just after starting it

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: vincent-moz, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030410
Build Identifier: http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-source.tar.bz2 (see below for more information)

When I start Mozilla, it crashes. This seems to be due to the calendar.

Reproducible: Always

Steps to Reproduce:
1. Start mozilla (without any argument).
Actual Results:  
The Calendar window appears (with nothing in it) and Mozilla crashes.

Expected Results:  
Mozilla shouldn't crash.

Here's what I get in the terminal:

greux:~> mozilla


Welcome to jslib version 0.1.123

Global Constants:

JS_LIBRARY     
        jslib
JS_LIB_FILE    
        jslib.js
JS_LIB_PATH    
        chrome://calendar/content/jslib/
JS_LIB_VERSION 
        0.1.123
JS_LIB_AUTHORS 
        Pete Collins       <petejc@mozdevgroup.com>
        Eric Plaster       <plaster@urbanrage.com>
        Martin.T.Kutschker <Martin.T.Kutschker@blackbox.net>
JS_LIB_BUILD   
        mozilla 1.3+
JS_LIB_ABOUT   
        This is an effort to provide a fully functional js library
        for mozilla package authors to use in their applications
JS_LIB_HOME    
        http://jslib.mozdev.org/

Global Variables:

  JS_LIB_DEBUG
  JS_LIB_ERROR




*********************
JS_LIB DEBUG IS ON
*********************


chrome://calendar/content/jslib/io/io.js
chrome://calendar/content/jslib/io/filesystem.js
*** load: filesystem.js OK
chrome://calendar/content/jslib/io/file.js
*** load: file.js OK
chrome://calendar/content/jslib/io/dir.js
*** load: dir.js OK
chrome://calendar/content/jslib/io/fileUtils.js
*** load: fileUtils.js OK
chrome://calendar/content/jslib/io/dirUtils.js
*** load: dirUtils.js OK
chrome://calendar/content/jslib/rdf/rdf.js
chrome://calendar/content/jslib/rdf/rdfBase.js
*** load: rdfBase.js OK
chrome://calendar/content/jslib/rdf/rdfResource.js
*** load: rdfResource.js OK
chrome://calendar/content/jslib/rdf/rdfContainer.js
*** load: rdfContainer.js OK
*** load: rdf.js OK
chrome://calendar/content/jslib/rdf/rdfFile.js
*** load: rdfFile.js OK
* RDFFile: Opening file 

* RDFFile: doing remote init 

* RDFFile: refresh remote 

entering getNode
entering getNode
entering getNode
caEvent.alarmWentOff is [xpconnect wrapped oeIICalEventDisplay]
Fire alarm [xpconnect wrapped oeIICalEventDisplay]
caEvent.alarmWentOff is [xpconnect wrapped oeIICalEventDisplay]
Fire alarm [xpconnect wrapped oeIICalEventDisplay]

CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selection

in unifinder onselect

multiweekView.js:
clearSelectedEvent/home/lefevre/mozilla/lib/mozilla-1.7a/run-mozilla.sh: line
451:  8211 Segmentation fault      (core dumped) "$prog" ${1+"$@"}
zsh: exit 139   mozilla


and the backtrace:

(gdb) backtrace 
#0  0x40ddc545 in NSGetModule ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libgklayout.so
#1  0x40ddc658 in NSGetModule ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libgklayout.so
#2  0x40de2ccf in NSGetModule ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libgklayout.so
#3  0x40ddbf84 in NSGetModule ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libgklayout.so
#4  0x4103ec7a in ?? ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libwidget_gtk.so
#5  0xbfe0119c in ?? ()
#6  0x00000018 in ?? ()
#7  0x40585d00 in __after_morecore_hook () from /lib/libc.so.6
#8  0x40585290 in ?? () from /lib/libc.so.6
#9  0x088f3028 in ?? ()
#10 0x088f3028 in ?? ()
#11 0xbfe01144 in ?? ()
#12 0x4103eb27 in ?? ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libwidget_gtk.so
#13 0x088f3028 in ?? ()
#14 0xbfe0119c in ?? ()
#15 0xbfe01138 in ?? ()
#16 0x4103d4e7 in ?? ()
   from /home/lefevre/mozilla/lib/mozilla-1.7a/components/libwidget_gtk.so
#17 0x088f3028 in ?? ()
#18 0x088f3028 in ?? ()
#19 0xbfe01164 in ?? ()


I compiled Mozilla yesterday from the nightly with "make -f client.mk" and the
following .mozconfig:

# Perl program (Mozilla takes perl5 by default, which can lead to clashes)
PERL=perl

# Options for 'configure' (same as command-line options).
ac_add_options --prefix=$HOME/mozilla
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-png
ac_add_options --with-system-mng
ac_add_options --enable-calendar
ac_add_options --enable-xft
ac_add_options --enable-crypto
ac_add_options --disable-debug
ac_add_options --enable-optimize=-O2
ac_add_options --enable-reorder
ac_add_options --enable-strip
ac_add_options --enable-xterm-updates

# SVG support - see http://www.mozilla.org/projects/svg/build.html
ac_add_options --enable-svg
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
MOZ_INTERNAL_LIBART_LGPL=1
(Assignee)

Comment 1

15 years ago
I'm building now to test. Meanwhile can you try to manually remove the events
that have alarms to see if it solves the problem?
(Reporter)

Comment 2

15 years ago
Yes, this solves the problem.
Please mark this as works for me if this bug isn't an issue anymore.
(Reporter)

Comment 4

14 years ago
Last time I tried with alarms at startup, there was no problem. -> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.