Queries results in an editable view of the bugs

RESOLVED DUPLICATE of bug 135595

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 135595
15 years ago
6 years ago

People

(Reporter: mohamed.abdallah, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: 

The result of a query produces a list of bugs that are editable. The query 
result of bugs should be read-only, with an optional "Edit/Modufy" button for 
users who have persmissions to do so.

Reproducible: Always

Steps to Reproduce:
1. Submit a bug query.
2. Click on one of the bugs in the output list.
3.

Actual Results:  
Bugzilla produced an editable view of the bug.

Expected Results:  
Bugzilla should have produced a read-only view/report of the bug.
In Bugzilla 2.17.3 or later you can assign a "canedit" group or groups to each
product.  A user must be a member of all of the groups checked in the canedit
column in the group controls for that product in order to edit a bug in that
product.  However, you still get the edit form, it just kicks out any change you
try to make with an error.

Bug 135595 will fix the above-mentioned shortcoming of the feature, which is the
only part of this left, so making this a dupe.

*** This bug has been marked as a duplicate of 135595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.