WMP Windows Media Player won't with "asx" file when MIME is "application/asx"

RESOLVED WORKSFORME

Status

Plugins Graveyard
Windows Media Player (Microsoft)
RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: Sam Malenfant, Assigned: Peter Lubczynski)

Tracking

x86
Windows XP

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Clicking on an "asx" video file link (in the page
"http://www.festivals.ca/sussex/wsis/harvard/harvard-eng.html") with a returned
MIME type of "application/asx" results in an empty page instead of firing up the
Windows Media Player when the plugin is used.


Reproducible: Always

Steps to Reproduce:
1. Go to page with "asx" file link
http://www.festivals.ca/sussex/wsis/harvard/harvard-eng.html and click  "asx"
link or paste the following in URL box
2. http://video.festivals.ca/bezanson_56.asx
3.
Actual Results:  
Displays empty page

Expected Results:  
Should have fired up WMPlayer

This CAN be made to work if the server's MIME type is other than
"application/asx", for instance "video/x-ms-asf" instead.

This can also be made to work if Mozilla "winpref.js" (C:\Program
Files\mozilla.org\Mozilla\defaults\pref) comments out the scan for WMP plugins

//pref("plugin.scan.WindowsMediaPlayer", "7.0");

AND a "helper application" is specifically configured for "application/asx" with
"wmplayer.exe".

So, the problem seems to be that the WMPlayer plugin (npdsplay.dll) cannot
handle the indirect invocation of the external wmplayer application indicated in
the "asx" file when the MIME type is "application/asx".  (Unfortunately I cannot
change the server, nor request all Mozilla users to change their configs).

The "asx" file contains:

<ASX Version="3.0">
<ENTRY>
<REF href = "mms://real.magma.ca:1755/video.festivals.ca/bezanson_56.wmv" />
</ENTRY>
</ASX>

Pasting this file link (http://video.festivals.ca/bezanson_56.asx) or the "mms:"
link directly into wmplayer works fine, and a test html page with the "mms:"
link alone works OK too.

The "about:plugins" seems normal:

Windows Media Player Plug-in Dynamic Link Library
  File name: npdsplay.dll
  Npdsplay dll
MIME Type               Description               Suffixes  Enabled
application/asx         Media Files               *         Yes
video/x-ms-asf-plugin   Media Files               *         Yes
application/x-mplayer2  Media Files               *         Yes
video/x-ms-asf          Media Files               asf,asx,* Yes
video/x-ms-wm           Media Files               wm,*      Yes
audio/x-ms-wma          Media Files               wma,*     Yes
audio/x-ms-wax          Media Files               wax,*     Yes
video/x-ms-wmv          Media Files               wmv,*     Yes
video/x-ms-wvx          Media Files               wvx,*     Yes

(this disappears of course when the winpref.js comments it out)

Have tried upgrading from WMP 8 to 9.0 and adding in registry ShimInclusionList
entries with same repeatable results.  Have also manually deleted entries in
"...\Application Data\Mozilla\pluginreg.dat" and confirmed rebuild with no other
"asx" entries showing.  Of course IE (6.0) works fine.
So does the player register itself for the application/asx type?  If so, why is
this a Mozilla bug and not a bug in the player?
Summary: WMP Windows Media Player won't with "asx" file when MIME is "application/asx" → WMP Windows Media Player won't with "asx" file when MIME is "application/asx"
(Reporter)

Comment 2

14 years ago
While this could be argued as a bug in the Micrsoft npdsplay.dll plugin, it
would seem unlikely that Microsoft might fix it for Mozilla, and there are
certain conditions under which it works, just not the default one.

It works when the MIME type is "video/x-ms-asf" instead of "application/asx". 
Is there an interception, perhaps in npnull32.dll, that trips up with
"application" but not with "video"?

The "helper application" entry also lets it work when the plugin is disabled
(removed and "...\Mozilla\pluginreg.dat" rebuilt), so is there something in the
plugin *API* that does not pass through usefully?

I have also tried zapping a version of the DLL with a hex editor by making the
extensions "asf,asx,*" for "application/asx" (swapping with "video/x-ms-asf", to
keep the file size the same).  No luck.
(Reporter)

Comment 3

14 years ago
  OK, this is not really that important a bug in the universe of Mozilla
problems.  We have addressed it now by getting our own "video" server for the
tiny meta files and have added a line in the "mime.type" file for the workable
"video/x-ms-asf  asf asx".  Please close this and move on to more important things.

Cheers,

/Sam Malenfant
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Windows Media Player (Microsoft)
Product: Core → Plugins
QA Contact: microsoft-wmp
Version: Trunk → unspecified

Updated

8 years ago
Version: unspecified → 7.x
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.