Popups (such as errors) take middle-mouse-scroll control away

RESOLVED DUPLICATE of bug 203878

Status

()

--
minor
RESOLVED DUPLICATE of bug 203878
15 years ago
15 years ago

People

(Reporter: burnscharlesn, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Note:
A) You can middle-click in Mozilla, bring up a little up/down arrow icon and
scroll up or down ased on how you move the mouse.
B) Sometimes errors pop up. A common one for me is "The operation timed out when
attempting to contact ads.foo.com."
If you are scrolling with A, and B happens, you cannot control the scrolling
until B is taken care of. If you are already scrolling, say, to read a page from
top to bottom, and an error pops up--all errors MUST be taken care of before you
can change the state of A scrolling. Thus, scrolling will continue whether you
want it to or not, when an error occurs.

This seemed like the type of bug no one else would report, but as Firebird
evolves, it will be best to get rid of the many small annoynaces like this that
can add up to a less impressive browsing experience. This same problem may also
apply to doing other things in Firebird that a popup error probably shouldn't
interrupt.

Reproducible: Always

Steps to Reproduce:
1. Middle-scroll (middle-click and move the mouse down or up)
2. Go to a webpage that will have a server timeout. This can be faked by
blackholing an image server or something in your firewall, and visiting a page
that uses it.
3. I wanted to say "PROFIT!!!" here, but that's probably been done to death. :)

Actual Results:  
Have to remove all arror message dialogue boxes to change the state of this
scrolling.

Expected Results:  
Middle-clicking in the window should stop scrolling. Perhaps such scrolling
should be fully enabled, regardless of error messages. It would also be nice to
disable those annoying popup errors, but that's for another report.

Comment 1

15 years ago
> 3. I wanted to say "PROFIT!!!" here, but that's probably been done to death. :)

Correct.  See http://www.squarefree.com/archives/000254.html.


> Expected Results: Middle-clicking in the window should stop scrolling.

That would be hard to implement, because Mozilla uses OS features for dialog
modality. See bug 123913, bug 59314.  (I think it would make more sense to stop
scrolling immediately when the dialog appears, even if your solution were
feasible, because dialogs usually appear in the middle of what you're looking at).


> This seemed like the type of bug no one else would report

Actually, this is a dup of bug 203878.

I'll admit to using your heuristic (skip reporting bugs if I think it's likely
that other people have reported them), but it's always good to search.

I've read bug 203878 before, and I've changed its summary, so I have an unfair
advantage in searching for it.  I found it again by searching for "ALL scroll
dialog,modal".  "scroll dialog" would have worked too.

*** This bug has been marked as a duplicate of 203878 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.