right-click on print button should display same menu as drop-down menu

RESOLVED DUPLICATE of bug 90783

Status

SeaMonkey
UI Design
--
trivial
RESOLVED DUPLICATE of bug 90783
15 years ago
10 years ago

People

(Reporter: Markus Multrus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040102
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040102

This is a usability-bug: A right-click on 'Forward-' and 'Back-' button displays
exactly the same drop-down menu as a left-click on the small arrows just below.
The print button doesn't display nothing on a right-click. But for uniformity it
should behave the same way as the 'Back-' and 'Forward-' button... :)

Reproducible: Always

Steps to Reproduce:
1. Right-click on 'Print-' button


Actual Results:  
Nothing happens

Expected Results:  
Display the same drop-down menu as a left-click on the small arrow just below
displays.
Assignee: general → guifeatures
Component: Browser-General → XP Apps: GUI Features

Comment 1

15 years ago
This is a specific instance of bug 90783. However opinion there seemed to be
against the change, though IMHO it would be an improvement over trying to target
the drop down arrow.
Summary: righ-click on print button should display same menu as drop-down menu → right-click on print button should display same menu as drop-down menu
(Reporter)

Comment 2

15 years ago
Yeah, you're right. Well, do whatever you want to do, I can live with both
solutions (remove the right-click functionality from back and forward button or
add it to print button), but it should be uniform... IMHO we should add it to
the print button, cause there are (apart from back/forward) a lot of other
buttons/symbols which have this functionality (bookmarks in personal toolbar,
on-/offline symbol, security symbol) and it gives the browser a more intuitive
handling.

I'll mark this bug as a duplicate of bug 90783.

*** This bug has been marked as a duplicate of 90783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.