Closed Bug 230332 Opened 18 years ago Closed 18 years ago

Problem in Blogger blog entry frame

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: whorfin1, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(5 files, 5 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040106 Firebird/0.7+ (aebrahim)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040106 Firebird/0.7+ (aebrahim)

Using a TRUNK build of Firebird 0.7+, logging into Blogger and attempting to add
a new entry yields the following puzzling behavior:

- The second frame down the screen is supposed to have an entry area for the
blog post.  Instead, under the trunk build, there is no text entry area, and
only a small graphical arrow is visible (which is a normal page element).

- Pressing the graphical arrow causes the text entry box to appear, but
everything else disappears.

This appears to be strictly a trunk build issue, as the 0.8 branch build works
properly on this page.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.blogger.com
2. Log into your account and edit a blog
3. See details box for more info

Actual Results:  
See details

Expected Results:  
See details
Can you save the page to your hard drive and see if the problem still occurs? If
so, can you then post it here as an attachment?
Confirmed with Seamonkey trunk build 200410408, works in Firebird 0.7, regression.
Keywords: regression
code showing the problem :
http://pascal.chevrel.free.fr/temp/bug230332/post_form.pyra.htm
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firebird → Browser
Version: unspecified → Trunk
Assignee: blake → nobody
QA Contact: core.layout
*** Bug 232310 has been marked as a duplicate of this bug. ***
The problem exists on Mozilla 1.7a on Windows 98 and Linux. It was OK on 1.6.

pi
OS: Windows 2000 → All
Still seeing it in recent mozilla and firefox builds, blogging is very important
today and blogger.com is an important player in this field, requesting this to
be a blocker for 1.7b, I shouldn't have to use IE to blog :-(
Severity: normal → major
Flags: blocking1.7b?
Flags: blocking1.7b? → blocking1.7b+
We really need a reduced testcase here. One that doesn't have a whole lot of
Javascript in it (preferably, none).
Attached file testcase (obsolete) —
<html><head><title>Post Form</title>

</head>
<body>

<div style="border: 1px solid red; color: red">
	<textarea style="height:100%;">textarea inside the div with
height:100%;</textarea>
	The red border is a div with no relevant attributes or style.
</div>


</body></html>
Keywords: testcase
Hardware: PC → All
I don't see how the testcase demonstrates the bug.
Attached file testcase numero dos
Perhaps this IE bug is more to your liking? The textarea is 100% wide, and
there's a floating div on the right. Moz moves the textarea below the div so it
can be 100% wide. IE leaves it on the same level.
Attachment #143772 - Attachment is obsolete: true
(In reply to comment #11)
> Created an attachment (id=143775)
> testcase numero dos
> 
> Perhaps this IE bug is more to your liking? The textarea is 100% wide, and
> there's a floating div on the right. Moz moves the textarea below the div so it
> can be 100% wide. IE leaves it on the same level.

Which MsIE version(s) are you testing with ?


[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113] (W98SE)

Mozilla v1.6 display:

(---- textarea -----) (- div -)


[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040219] (W98SE)
[Microsoft Internet Explorer, version 5 (5.00.3105.0106) (128b, SP1)] (W98SE)

Mozilla v1.7a display (== MsIE v5.00sp1):

(----- empty ------) (- div -)
(--------  textarea  --------)
(FWIW)

[Netscape® Communicator 4.8 : en-20020722] (W98SE)

NNv4.8 displays as Mozilla v1.6 does:

(---- textarea -----) (- div -)
IE6 shows it

(---- textarea -----) (- div -)


Fx 20040302 and Sm 2004020708 shows it

(----- empty ------) (- div -)
(--------  textarea  --------)
the testcase regressed between linux trunk 2003121808 and 2003121909.  bug 97695
looks like the only thing relevant.
As far as I can tell, the new layout is correct.
Assignee: nobody → english-us
Component: Layout → English US
Product: Browser → Tech Evangelism
QA Contact: core.layout → english-us
Version: Trunk → unspecified
David, could you give an explanation to send to the blogger stuff (they usually
respond quickly) why Mozilla is correct and their page is broken? Or did someone
already do this?

Certainly, it will be bad for Mozilla if that page does not work.

pi
Attached image Shot of the correct rendering. (obsolete) —
This is the first of two screen caps to show the exact bug referenced
originally. Here is the correct rendering as done by Firefox 0.8.
Attached image Shot of the incorrect rendering. (obsolete) —
This is the incorrect version, as seen in Mozilla 1.7b.
Attached image This shows the correct rendering. (obsolete) —
Attachment #144551 - Attachment is obsolete: true
Attached image This shows the incorrect rendering. (obsolete) —
Attachment #144552 - Attachment is obsolete: true
You still can access the form by scrolling. But there is no scrollbar. This
seems to be a bug in Mozilla. I am not entirely sure if this is only their
fault. Still I would like to know what they make wrong.

pi
The inability to scroll seems like a bug.  Perhaps file one?
David, I don't fully understand what's going wrong. I guess you understand it
better and can file a much more informed bug. Also, it would be great if you
could say, what exactly the error with Blogger is and why it worked before.

pi
This bug occurs for me in all Mozilla 1.7 and 1.8 builds under WinXP, but is
fixed when I reinstall Mozilla 1.6. I have written to the Blogger folks
suggesting to them that they collaborate with you on fixing this. As I have been
a longtime customer of Blogger Pro (the paid version) with a very low bloggerID
(early adopter), they are supposed to listen more to my concerns.
This problem occurs for me in Mozilla 1.7b but not in K-Meleon.  Is there
possibly another alternative Blogger could use than 100% that will make the
textarea as wide as possible without bumping down a line.  IMHO, a table might work.
Eliot, I suppose the recommendation to blogger is to change the textarea and
floated div widths to use percentages which add up to slightly less than 100% to
get the desired layout. E.g. 74% and 25%. Can you contact them as a subscriber?

I guess I just don't get floats in all their incarnations. If you change the
textarea in the testcase dos to a div, you get the "desired" layout even though
the background of the div appears under the floated div. If you change the
textarea to a span you also get the desired layout since the width is
meaningless. If you add display: block to the textarea, the textarea takes up
the entire width and the floated div disappears unless you make the window
extremely narrow. Putting display: inline on the textarea is the same as no
display property at all.
After upgrading to the latest nightly builds of Camino and Firefox (both OSX versions). the Problem 
even got worse: Now the entry-field for the blogtext is just about 4 pixels in hight an it impossible to 
enter or edit text. Very annoying!!!
Anyone else think this needs to be changed from "evangelism"? Is this not a
rendering bug occurring in Mozilla? Has blogger.com changed their template in
the past day to cause this new COMPLETELY unusable change?

If this is rendering related at all... this is a BIG usability problem, and IS
in the 1.7 branch... should be set as a blocker.
From the comments here, the problem originally described wasn't a Mozilla
problem. If there's a new issue, you should file a new bug, with the page
attached, or a testcase.
Actually, I have not found (or understood) what exactly is wrong on the side of
Blogger. My question in comment 24 is unanswered. Without that information it is
hard to decide who's wrong.

pi
http://www.w3.org/TR/CSS21/visudet.html#containing-block-details says:
  For other elements, if the element's position is 'relative' or 'static',
  the containing block is formed by the content edge of the nearest block-level,
  table cell or inline-block ancestor box.

http://www.w3.org/TR/CSS21/visudet.html#the-width-property says:
  Percentages:  	refer to width of containing block

That explains why the textarea must be the width of the page.  The reason it
moves below the textarea is given here:

http://www.w3.org/TR/CSS21/visuren.html#floats
  If a shortened line box is too small to contain any further content, then
  it is shifted downward until either it fits or there are no more floats
  present.

The other issues mentioned in this bug (comment 22, comment 28) have not been
analyzed and do not belong in this bug.  Separate bugs should be filed. 
Further, this analysis is based on the testcase in comment 11 (attachment
143775 [details]), not the original page.  If the testcase is incorrect, then this bug
needs further analysis.
I just set up a blogger account at http://planet10.blogspot.com using the free
hosting service. I can not reproduce the problems described in this bug using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040505 or
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040505.

For the people who are having problems, please send your ua strings, your choice
of templates and any customizations you have made to your template, the source
for the problem page and a screenshot of the problem. Please also confirm the
problem exists in a new, fresh profile.
err, the second ua should have been Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7) Gecko/20040427
Attached file Source Code
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040505
Firefox/0.8.0+
And that's on a just this afternoon installed windows pc. Default theme.
And a screenshot of this problem.
This is on a brand new blog I just created, shown in Internet Explorer the way
it is meant to be displayed.
Attachment #144579 - Attachment is obsolete: true
This shows the incorrect rendering from 20040506 Firefox/0.8+ Zip install. The
form is totally unusable now.

(note - in both these attachments, the extra whitespace below the Windows
Taskbar seems to have been added by GIMP2 somehow, please ignore)
Attachment #144580 - Attachment is obsolete: true
Also, as was discovered via an off-bugzilla correspondance yesterday:

To those that aren't seeing the screen in question in my example pics... be sure
to go into your blogger.com preferences and tell it to use "Classic Style" for
the interface. You should then see the horribly broken version.

Yippee.
Blogger has just revamped their blogging system which now works perfectly,
marking fixed.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Right.

pi
Status: RESOLVED → VERIFIED
Wow, Blogger just released a completely new blogger-system and pretty new interface! Say bye, bye to 
the annoying bugs on the blog-entry page we discussed here. These problems are history now.

By the way: the new interface of Blogger is quite nice, and somehow reminds me of a mix between 
MacOS X and Win XP GUI-Elements. All the new elements seem a little to big though, but this may 
change over time.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.