Functions bound to focus or blur events not run when event occurs on text input elements

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
16 years ago
12 years ago

People

(Reporter: alex.murray, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040107
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040107

Functions bound to the focus and blur events are not run when the events occur
on text input elements - bound functions run as they should when the events
occur on select elements (for example). 

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Posted file Test case
Passing focus to the Select object also seems to fire an extraneous blur event
before the focus event. Not sure if this is a bug.
focus events just don't bubble from text inputs.  Arguably, they should not
bubble at all (per the spec, they shouldn't).
Depends on: 4033
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 286613 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
Sure this is a bug. Doing complex forms with all events bugs is impossible.

It seems that "event code" has not been reviewed since a long time ago.

Bug confirmed in FF 2.0.4
Per DOM Events recommendation focus and blur events don't bubble, so
capturing event listeners should be used. This bug is INVALID.
(It was a bug that focus and blur events did bubble in some cases.)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.