events can be inconsistent with respect to time-zone

RESOLVED WORKSFORME

Status

Calendar
Internal Components
--
minor
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Liam Morley, Assigned: John Gray)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Some events created from within the Mozilla Calendar program seem to carry
time-zone specific information, while others do not. here's an example. The
first one has no 'Z' for DTSTART and DTEND, and there is no timezone offset (it
is supposed to start at 9am, and it does). The second one does include the 'Z',
and there is a timezone offset.

The bug is that these were created in the same manner, and are even in the same
file. You'd think that both would carry the timezone information?

BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
BEGIN:VEVENT
UID
 :1dc1d300-4007-11d8-abb0-f2f8ee1767a7
SUMMARY
 :My First Event
LOCATION
 :My First Location
STATUS
 :CONFIRMED
CLASS
 :PUBLIC
RRULE
 :FREQ=WEEKLY;INTERVAL=1;BYDAY=SU,SA
DTSTART
 :20040110T090000
DTEND
 :20040110T170000
DTSTAMP
 :20040106T051315Z
LAST-MODIFIED
 :20040107T162829Z
END:VEVENT
END:VCALENDAR

BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
BEGIN:VEVENT
UID
 :940663429
SUMMARY
 :My Second Event
LOCATION
 :My Second Location
STATUS
 :TENTATIVE
CLASS
 :PUBLIC
RRULE
 :FREQ=WEEKLY;INTERVAL=1;BYDAY=MO,TU,TH,FR
EXDATE
 :20031031T000000
EXDATE
 :20031127T000000
EXDATE
 :20031225T000000
EXDATE
 :20040108T000000
DTSTART
 :20031013T200000Z
DTEND
 :20031014T020000Z
DTSTAMP
 :20031007T023818Z
LAST-MODIFIED
 :20040107T162853Z
END:VEVENT
END:VCALENDAR

---

I'd be happy to include all of my ical files upon request.

Reproducible: Sometimes

Steps to Reproduce:
This seems to be file-dependent. If I create a new event spanning 9am to 5pm in
one calendar, it will retain the 'Z' and timezone information. However if I
originally create the same event but assign it to a different calendar file, the
timezone information will not be kept. (The second example was created some time
ago, I'm not sure why new events created in the same file no longer have the 'Z'?)

1. set time zone (mine is set to America/New_York)
2. create a new event
3. take a look at ical file to see whether or not timezone information was kept

Actual Results:  
Depending on which file the event was created in/assigned to, timezone
information may or may not be kept.

Expected Results:  
Mozilla Calendar should either be consistent across different files AS WELL AS
within the same file over time, or give the user the option (somewhere in the
GUI) to specify which files are timezone-specific and which are not.

Comment 2

14 years ago
Time zones information is saved if you have the option "Store dates in
Universal Time" set in Tools->Option->General. Mind that it's the setting of
this option at the time an event is created (or changed) that is significant. 

Comment 3

13 years ago
The "Store dates in Universal Time" setting is sometimes ignored though. If you
create a new event then everything is OK, but if you copy and paste that event
then the new event is stored in Universal Time (i.e. with a Z).

After copying and pasting, I always edit the .ics file manually.

Updated

13 years ago
QA Contact: gurganbl → libical

Comment 4

13 years ago
All events in current nightly builds will carry timezone information now.  Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Component: libical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: libical → base
You need to log in before you can comment on or make changes to this bug.