cannot create folder in "Bookmarks Toolbar" using context menu

VERIFIED FIXED in Firebird0.8

Status

()

VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: ahmetafsinakin, Assigned: p_ch)

Tracking

({regression})

unspecified
Firebird0.8
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+

i cannot create a new bookmark folder by using right click on bookmark toolbar
and choosing "new folder"

Reproducible: Always

Steps to Reproduce:
1. right click on empty area on bookmark toolbar
2. choose "new folder"
3.

Actual Results:  
nothing happens

Expected Results:  
new folder dialog should appear

Updated

15 years ago
Keywords: regression

Comment 1

15 years ago
Confirming with 0.8 branch build 20040102, Win XP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking0.8?
has this ever worked?  I don't have older nightlies to test, but unless someone
can definitely say it has been working at some point, its not really a regression.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040107 Firebird/0.7+
(daihard; XFT+GTK2; optimized for P4/SSE-2)

Nothing happens - I don't even get a dialog.
(Reporter)

Comment 4

15 years ago
yes i actually used it several times.
DO you remember which build it worked on?

Comment 6

15 years ago
Created attachment 138708 [details] [diff] [review]
Proposed fix for bookmarks menu

This patch appears to fix the problem.
The add was failing because hidePopup was being called on an object
without that method (the new folder dialog).

I'm not really sure this is the correct fix. Someone with more
expertise on this code should look at this.
(Reporter)

Comment 7

15 years ago
ok. for example in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031203
Firebird/0.7+
works well.
(Assignee)

Comment 8

15 years ago
I refactored the patch, but the idea was correct.
marking fixed (trunk and branch)
> marking fixed

??  or was it not *the bug* that you were talking about being fixed?
(Assignee)

Comment 10

15 years ago
oops, really marking fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Target Milestone: --- → Firebird0.8
Yup, definitely fixed.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040110 Firebird/0.8.0+
(daihard: XFT+GTK2; optimized for P4/SSE-2)
v.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Flags: blocking0.8?
Removing self from CC list.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.