Unread count does not increase when new msgs arrive via biff

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: lchiang, Assigned: gayatrib)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Unread count does not increase when new msgs arrive via biff

Win32 2000-01-03-09-m13 release build

Setup:  I have a folder which new messages get filtered to if a criteria is
matched.  Using IMAP and biff interval is set:
user_pref("mail.imap.server.vadar.check_new_mail", true);
user_pref("mail.imap.server.vadar.check_time", 5);

1) I'm currently in the folder that new msgs get filtered to.  Unread count is
correct. (Let's say it shows (2) in the folder pane in bold.)

2) Select an unread message and the unread count decreases by 1.

3) At this time, the interval for biff starts and additional new messages show
up in the folder

Actual results:  The unread count in the folder pane still shows (1) and does
not increase to reflect the new messages coming in.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → fenella
(Reporter)

Comment 1

18 years ago
I also see this on the Win32 1/4 release build.  I'm wondering if this is a
timing issue where I am reading through messages and the unread count is
decreasing as new messages come in via biff (?)

Comment 2

18 years ago
please see bug 23058 and 23063 for more about biff.

Comment 3

18 years ago
I've still never seen this :)  Are all of the counts off (the one next to the
folder name as well as the one on the status bar?).
Status: NEW → ASSIGNED
Target Milestone: M18
(Reporter)

Comment 4

18 years ago
darn. I'm supposed to try to reproduce this for you. I still see this.

Comment 5

18 years ago
reassigning to gayatrib. lchiang, are you still seeing this?
Assignee: putterman → gayatrib
Status: ASSIGNED → NEW
(Reporter)

Comment 6

18 years ago
I have not seen it recently, but I have to double check.
(Assignee)

Comment 7

18 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Win32 (2000-06-26-09 M17)
Unread count increase when new msga arrive via biff on Win_nt 4.0
However, it does not work on Mac and Linux.  I think it has to do with bug
43872.
Reopen this bug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

18 years ago
Fenella, if you can't use biff on Mac and Linux, how can you tell if the unread 
count is increasing when biff goes off?

Comment 10

18 years ago
Oh, Scott, that's what I meant. Since biff on the 6/26 build on Linux and Mac 
does not go off, I am unable to test the unread count. 
Will test it again..
(Reporter)

Comment 11

18 years ago
Fenella, this bug should be mark fixed again.  If you can't test the fix due to 
a more recent bug (43872), just note in this bug and wait until bug 43872 is 
fixed before verifying this bug.  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
Win32 (2000-07-05-09 M17)
Linux (2000-07-05-08 M17)
Mac (2000-07-05-11 M17)
This bug is fixed now.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.