With IMAP account, marked junk mail is unmarked when automatically moved to another folder

RESOLVED DUPLICATE of bug 191750

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 191750
14 years ago
10 years ago

People

(Reporter: Philip walden, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4) Gecko/20030707
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4) Gecko/20030707

I have two different mail accounts. At work I have an IMAP mail server to MS
Exchange. At home, I have a POP connection to my ISP.

With the IMAP account, I have my junk mail control automatically move junk mail
to  the junk folder. I also have manually marked junk mail moved to the same
folder. However, when the marked junk mail arrives in the new folder, it appears
to be no longer marked as junk. This behavior is observed on both my mozilla 1.4
HP-UX workstation and my mozilla 1.5-Windows 2000 laptop.

With my POP account, the marked junk mail stays marked as junk in the new
folder. This is exhibited both on a mozilla 1.5-Windows XP workstation and a
mozilla 1.5-Linux 2.4 workstation.

Reproducible: Always

Steps to Reproduce:
1. Create a IMAP mail account
2. Set Junk mail controls to move manually marked junk mail to another folder:
Junk, Trash, ... does not matter
3. Select an Inbox mail item and mark it as junk
4. Note: the junk flag appears and the junk header ("mozilla thinks this message
is junk")appears in the message window.
5. The mail item should then disappear as it moves to the destination folder
6. Select the destination folder and observe that the mail item is no longer
marked as junk mail



Expected Results:  
The mail item in the destination folder should remain marked as junk mail. With
my  POP mail account this is the case.

Comment 1

14 years ago
using "junk" "flag" and "mov" [yes, "mov"] as search terms i found a few likely
dupes, which are all duped to bug 191750.

If you experience another problem than described there then please reopen this bug.

*** This bug has been marked as a duplicate of 191750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.