unwanted folders (Sent, Templates, Drafts) should not be created again

RESOLVED DUPLICATE of bug 197228

Status

RESOLVED DUPLICATE of bug 197228
15 years ago
12 years ago

People

(Reporter: andre, Assigned: mscott)

Tracking

unspecified
Thunderbird 11.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
(actually this is Mail Window Back End but its not selectable)

see bug 35310 "Unwanted folders should not be created again."

1) you have got a few accounts (eg.5) each with Sent,Templates, Drafts. if you
want to use the local account for that it could save you accounts# x 3 entries
there (eg. 15)
2) this is a workaround to be able to delete folders:
if you go to the prefs and change for all accounts a) all (in "copies&folders")
these 3 for all accounts to OTHER (accept the default setting here) b) confirm
with OK button c) go back to the prefs and change them all to "X folder on:
Local Folders" d) confirm with OK e) for all folders in [Edit] -> [Delete
Folder] should be available
3) delete them all
4) close TB
5) start TB
6) They're all back, sigh

this really is embarassing, I got only 6 accounts and already waste 18 entries
(Reporter)

Comment 1

15 years ago
adding keyword mail3, proposing for tb 0.6
Keywords: mail3
Target Milestone: --- → Thunderbird0.6
(Reporter)

Comment 2

15 years ago
interstingly this only happens for imported (by copying) account, not for newly
created ones as far as I can see for now...
(Assignee)

Comment 3

15 years ago
only developers can target milestone fixes for bugs.

This is a huge feature that will take a lot of time. Won't happen till after 1.0
Keywords: mail3
Target Milestone: Thunderbird0.6 → After Thunderbird 1.

Comment 4

15 years ago
(In reply to comment #3)
> This is a huge feature that will take a lot of time. Won't happen till after 1.0

Isn't this also pretty much a dup of 197228? That one explains things really
well, I think.

And I'd really kind of hate to put this off until 1.0 - it's really a
common-sense thing to a lot of people, and having a lot of extra folders that
aren't necessary, often requiring excessive scrolling, can get annoying really fast.

Comment 5

14 years ago
I'm getting thin on Moz 1.8 as well.  When the Mail GUI starts for the first
time after moz is started, a Templates folder is created in the account section
of my IMAP account.  When the mail server is contacted, the folder disappears
because it doesn't exist on the server.  In addtion, I cannot delete the Drafts
or Templates folders of the POP account either.
Depends on: 197228
No longer depends on: 35310
OS: Windows XP → All

Comment 6

14 years ago
(In reply to comment #5)
> In addtion, I cannot delete the Drafts
> or Templates folders of the POP account either.

I just wanted to save a mail as draft but it didn't go to the local folders'
drafts folder but to the the pop.account's draft folder associated with the
"personality" ("from:" field) I decided to send it with. This seems only to
happen when I create a mail with a "from:" field associated with the primary
(the first one ever created) mail account.

Should this be a new bug or is it related to this one or ...?
Yes, afaiui the "Copies & Folders" prefs on where to save Drafts, Sent et al.
are identity-specific, and the "Copies & Folders" prefs appearing under each
incoming account in Account Settings are those of the default identity related
to that incoming account. See also Account Settings -> [account] -> Manage
Identites... -> [identity] -> Edit...

And no, this bug is not about messages going into unexpected places, but about
folders appearing which no messages would go into anyway.

Comment 8

13 years ago
In reply to comment #3
> This is a huge feature that will take a lot of time.

Huge feature??? There's a *two* line workaround here:
https://bugzilla.mozilla.org/show_bug.cgi?id=197228#c19.

This bug should be a dup of that one, BTW.

*** This bug has been marked as a duplicate of 197228 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
No longer depends on: 197228
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.