Display webpage when loading is canceled even if not all scripts are loaded

NEW
Unassigned

Status

()

P5
normal
15 years ago
5 months ago

People

(Reporter: timwi, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Suppose you have a huge HTML page. You don't want to have to wait for it to
finish loading, so you press Esc and it will display just the top bit.

HOWEVER, and this is the problem, if the page is small and loads just fine, but
the style sheet or any other page-global part that is needed to display the page
refuses to load, then pressing Esc to cancel the load leaves an empty window
even though all the HTML has been downloaded and should be available for display.

Alternatively, of course, Mozilla could *always* display everything it's got
instead of waiting for the style sheet. Of course this would mean re-rendering
the entire page once the style sheet is available, and whether that is a problem
or not I will leave to others to judge.

I am unsure whether this is a feature request or a bug. The description of the
"minor" severity says it applies when there is an easy workaround, and for this,
there isn't.


Reproducible: Always

Steps to Reproduce:

1. Edit your hosts file and set "stat.livejournal.com" to some IP that doesn't
respond
2. Try to load http://www.livejournal.com/
3. Wait some time so it has a chance to load the HTML, but press Esc before the
non-responding request for the style sheet times out.

Actual Results:  
Page is blank.

Expected Results:  
Page should display without the stylesheet information.

Updated

15 years ago
Whiteboard: DUPEME

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 220142 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Reopening; the other bug covers stylesheets; this should probably cover scripts
(since it covers all "page-global" objects....).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Display webpage when loading is canceled → Display webpage when loading is canceled even if not all scripts are loaded
To DOM to decide whether it's ok to display a page with scripts that failed to load.
Assignee: general → general
Component: Browser-General → DOM
QA Contact: general → ian

Comment 4

14 years ago
(Seen also with Linux builds)

Just for information, Konqueror and Opera both display HTML even if the slow
script isn't still loaded.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: general → nobody
QA Contact: ian → general
https://bugzilla.mozilla.org/show_bug.cgi?id=1472046

Move all DOM bugs that haven’t been updated in more than 3 years and has no one currently assigned to P5.

If you have questions, please contact :mdaly.
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.