ftp.gimp.org hangs Firebird at 100% CPU

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
critical
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: David Gerard, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+

If you go to ftp://ftp.gimp.org/pub/gimp/v2.0/testing/README in this version of
Firebird, it accesses the site then hangs at 100% CPU.

Reproducible: Always

Steps to Reproduce:
1. Go to ftp://ftp.gimp.org/pub/gimp/v2.0/testing/README

Actual Results:  
Hangs at 100% CPU

Expected Results:  
Load the file.

It's just a short text file that loads fine in IE 5.5.

Comment 1

14 years ago
Tested this using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102
Firebird/0.7+

1. Initially had some problems - couldn't get the file, but no crash/hang.
2. Tried same thing in IE - got IE error message where you can "detect network
settings" etc...
3. Tried via ftp.exe session, could log in anonymously fine, and could get the
file ok.  The permissions were fine: rw-rw-r
4. Tried again in IE - worked.
5. Tried again in Firebird - worked.
6. Tried again in IE - failed, then worked.

Possibly just a busy FTP server?

David, try some more testing using a few different methods and report back with
your findings.

Comment 2

14 years ago
WFM, build 20040102, Windows XP.
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20040102 Firebird/0.7+

possibly just an overloaded server, given the results in comment 1

QA Contact: mconnor
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040107 Firebird/0.7+
(daihard; XFT+GTK2; optimized for P4/SSE-2)

Works fine. Although why Firebird would hang because of an overloaded server is
something I'm not too sure about...

Comment 5

14 years ago
Also works for me using Mozilla/5.0 (Windows NT 5.0; rv:1.7a) Gecko/20040109
Firebird/0.8.0+

Now that we have five people with different setups reporting this to be working
I'm resolving this. 
David, please try it again with a fresh profile or with reinstalling.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.