very huge computed height on absolute positioned list

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Vicente Alabau, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

very huge computed height (1.2324e+006px) on li element
before first li element there is a big space

Reproducible: Always

Steps to Reproduce:
Next small code as is.
It's a piece of validated standart html code.
--------------- BEGIN bug.html -----------------------
<?xml version="1.0" encoding="iso-8859-15"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>Bug</title>
    <style type="text/css">
      ul {
        position: absolute;
        text-align: right;
        left: 0px;
        top: 0px;
      }    
    </style>
  </head>
  <body>
      <ul>
        <li><a href="#">Visión de Futuro</a> </li>
        <li><a href="#">Another link</a></li>
      </ul>
  </body>
</html>
--------------- END bug.html -----------------------

Actual Results:  
before first li element there is a big space
very huge computed height (1.2324e+006px) on li element.
can be seen in DOM Inspector

Expected Results:  
list should flow normaly, second li must be just after the first one.

Note the space '<li><a href="#">Visión de Futuro</a> </li>' between '</a>' and
'</li>'.
If removed display is right. The same if 'text-align: right;' is removed or if
'ó' from 'Visión' is deleted.

Comment 1

15 years ago
Created attachment 138702 [details]
Testcase

Submitters example code

Comment 2

15 years ago
This WFM using Mozilla nightly 2004010608 on Windows 2000
Worskforme as well, on Linux trunk build 2004-01-04-08.  Marking so, since 1.4
is pretty old.  Please reopen if this is reproducible in a recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
Created attachment 138726 [details]
submitters testcase

the first testcase starts:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>

Submitter´s testcase starts:
<?xml version="1.0" encoding="iso-8859-15"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

and they are displaying differently, 2nd testcase shows a single blank line,
not a huge gap, with current nightly. I will retest with Mozilla 1.4.1
In standards mode you will get the 1em top margin on the list.

Comment 6

15 years ago
Just tested with Mozilla 1.4.1, same behaviour as in a current nightly:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4.1) Gecko/20031008
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040108

testcase #1 renders in quirksmode, testcase #2 in standards compliance mode,
showing the 1em top margin on the list.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.