CSS doesn't redirect to the proper xbl binding

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Manel Mateos, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

this doesn't work in firebird 0.7:
Customtag1 innertag {
	-moz-binding:url("/myfile.xbl#CUSTOMTAG1");
}
Customtag2 innertag {
	-moz-binding:url("/myfile.xbl#CUSTOMTAG2");
}

Reproducible: Always

Steps to Reproduce:
create a xul file with 2 customtags redirected by css to two diferent bindings
with the estructure above. 

Actual Results:  
the customtag doesn't redirect to the proper binding!
Please attach a testcase showing the problem to this bug using
http://bugzilla.mozilla.org/attachment.cgi?bugid=230493&action=enter (and please
test in something more recent than 1.5).
Marking WORKSFORME.  Please reopen when you attach a testcase.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
Okey! I'm finding out what's happening... It's not a bug, but I have a binding 
extending "chrome://global/content/bindings/textbox.xml#textbox" but with 
mozilla FireBird it should 
be "chrome://global/content/widgets/textbox.xml#textbox"
why have you pakage the bindings under a different folder? 

tx in advance!
_we_ didn't.  Firebird did.  Most likely because the bindings are actually
different.
You need to log in before you can comment on or make changes to this bug.