bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Proxy: suggestions for improvement in configuration

VERIFIED DUPLICATE of bug 100523

Status

()

Core
Networking
--
enhancement
VERIFIED DUPLICATE of bug 100523
15 years ago
15 years ago

People

(Reporter: Pete, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 MultiZilla/1.5.0.4g
Build Identifier: 

As a laptop owner, I move between sites frequently. Unfortunately, selecting
between different proxy providers is very clumsy, requiring me to type in the
proxy location each time. It would be of great benefit if I could configure
'proxy groups' for different locations.

Reproducible: Always

Steps to Reproduce:
1. Office location 1: Open Browser preferences, go to proxy settings in advance
tab. Edit settings. Start browsing.
2. Office location 2: Open Browser preferences, go to proxy settings in advance
tab. Edit settings. Start browsing.
3. Office location 3: Open Browser preferences, go to proxy settings in advance
tab. Edit settings. Start browsing.
4. Office location 4: Remind self to post an enhancement suggestion to
http://bugzilla.mozilla.org. Open Browser preferences, go to proxy settings in
advance tab. Edit settings. Start browsing.
Actual Results:  
Became frustrated (again)

Expected Results:  
1. Office location 1: Open browser preference.
If required,
2a. Select 'New proxy group' button.
2b. Name 'proxy group' (name added to proxy dropdown selector).
2c. Input information as usual.
2d. Repeat procedure if necessary.
3. Select from drop-down box the name of the 'proxy group' for office location
required.


I might get around some time to mailing a dev of quickprefs (or similar) to
provide same.
Not a bug in the prefs dialog itself, but in a particular panel.
Assignee: prefs → darin
Component: Preferences → Networking
QA Contact: benc

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 100523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
VERIFIED/dupe.
Follow the dupe chain...
Status: RESOLVED → VERIFIED
Summary: Suggestions for improvement in proxy configuration preferences → Proxy: suggestions for improvement in configuration
You need to log in before you can comment on or make changes to this bug.