When using mplayerplug-in, the above url crashes galeon and epiphany after clicking the 'Back' button

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: jstrand1, Assigned: peterlubczynski-bugs)

Tracking

({crash})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031015 Epiphany/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031015 Epiphany/1.0

I wasn't sure where to file this, so I went with plugins.

Using the latest mplayer and mplayer plugin with both galeon and epiphany (gtk2
mozilla based browsers), clicking the back button after loading the above link
causes the browser to crash.  Mozilla does not crash.  Sometimes just leaving
the page while the movie is playing will cause a crash too-- however, pressing
the Back button always causes a crash.

gnome2.2 environment
mozilla 1.4
galeon 1.3.9
epiphany 1.0


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
I forgot to mention that this happens when using all content I have tried that
uses mplayer-- whether its quicktime, mms, or other.
(Reporter)

Comment 2

15 years ago
Created attachment 138759 [details]
strace of crash for galeon (gzipped)
Is that a gtk2 build of mozilla?  Or gtk1?  This could a gtk2-only problem....
(Reporter)

Comment 4

15 years ago
gtk2 mozilla build-- but mozilla functions properly.  Its galeon and epiphany
that have the problem.  Since both had the problem, I figured it had to do with
the embedding.

Updated

15 years ago
Severity: normal → critical
Keywords: crash

Comment 5

15 years ago
Got e-mail from mplayerplug-in author telling me it's fixed in CVS, will mark
WFM when next release is out (unless someone compiles CVS and report back).
See also bug 234423 comment 11.

Comment 6

15 years ago
Marking WFM to follow the CrashWeek effort:
http://www.mozillazine.org/articles/article4539.html

Reopen if crashing with mplayerplug-in from CVS or post 2.50
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → Mplayer
Product: Core → Plugins
QA Contact: mplayer
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.