Continuous scrolling does not work on Vertical scrollbar with Smooth Scrolling enabled

RESOLVED FIXED in Camino0.8

Status

Camino Graveyard
General
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Hiro, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7a) Gecko/20040110 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7a) Gecko/20040110 Camino/0.7+

When continuing pushing a mouse button on vertical scroll bar, scrolling is not
continued to the position of a mouse pointer.

This is working in Mozilla Firebird or Safari.

-- Mac OSX 10.3.2
-- Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7a)
Gecko/20040111 Firebird/0.8.0+
-- Safari 1.1 (v100.1)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Only scrolling for 1 page is carried out.

Expected Results:  
Scrolling is continued to the position of a mouse pointer.
Is this 10.3 specific (works fine for me on 10.2).

Comment 2

15 years ago
WFM 10.3.2, Build 2004011103

Comment 3

15 years ago
WFM 20040109 NB. 10.3.2.
(Reporter)

Comment 4

15 years ago
It checked again by nightly build 2004011103 & new profile.
It did not work, even if it continued pushing(mouse button does not release).
(Assignee)

Comment 5

15 years ago
I WFM'd a bug like this a while back. it appears for some people, i guess, and
not others. reporter, anything weird about your system? US system? any language
kits installed? 
(Reporter)

Comment 6

15 years ago
OS performed clean installation.
The language kit has chosen only English and Japanese.

The language environment is Japanese when logging in.
The weird phenomenon is not happened in the portion of especially others.
(Reporter)

Comment 7

15 years ago
When this problem occurred, the following logs were outputted to the console log
file.

2004-01-15 08:08:35.558 Camino[1300] *** -[ChildView 
_destinationFloatValueForScroller:]: selector not recognized
2004-01-15 08:08:35.560 Camino[1300] *** -[ChildView 
_destinationFloatValueForScroller:]: selector not recognized
(Assignee)

Comment 8

15 years ago
*** Bug 232528 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
10.3.2 (set to German)
Scrollbar set to scroll one page, scroll arrows together
Works correctly in Mozilla Classic, Modern, and Firebird

I get the same message in Console:

2004-01-29 15:56:55.973 Camino[1286] *** -[ChildView
_destinationFloatValueForScroller:]: selector not recognized
(Assignee)

Comment 10

15 years ago
ah-ha, you have smooth scrolling turned on. see, you have to tell me these
things ;) i can repro this only with that turned on.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Continuous scrolling does not work on Vertical scrollbar. → Continuous scrolling does not work on Vertical scrollbar with Smooth Scrolling enabled
Target Milestone: --- → Camino0.8
(Assignee)

Comment 11

15 years ago
hacked in a fix. i guess apple was assuming that any parent of a NSScroller was
a NSScrollView and having it send private, undocumented methods to implement
smooth scrolling. Gooooo Apple!
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

15 years ago
A setup of smoothscroll was checked.
This function was effective unawares;-P
Surely this problem was not reproduced when smoothscroll was turned OFF.

This problem's fixed by correction of Mike-san and I check later.
(Reporter)

Comment 13

15 years ago
It has checked that this bug had fixed.
2004013006 (v0.7+)
You need to log in before you can comment on or make changes to this bug.