Closed Bug 230639 Opened 21 years ago Closed 21 years ago

Crash after setting Disable XUL Cache, then OK on Preferences dialog

Categories

(Core :: Preferences: Backend, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 228730

People

(Reporter: WeirdAl, Unassigned)

Details

(Keywords: crash, testcase)

#0  0x405a46f6 in nanosleep () from /lib/libc.so.6
#1  0x0000001c in ?? ()
#2  0x0807211e in ah_crap_handler(int) (signum=11) at nsSigHandlers.cpp:135
#3  0x419487b9 in nsProfileLock::FatalSignalHandler(int) (signo=11) at
nsProfileLock.cpp:209
#4  0x4012bc2d in __pthread_sighandler () from /lib/libpthread.so.0
#5  0x4051fd58 in __libc_sigaction () from /lib/libc.so.6
#6  0x4148cdaa in nsXBLPrototypeHandler::ExecuteHandler(nsIDOMEventReceiver*,
nsIDOMEvent*) (this=0x8b5b630,
    aReceiver=0x8a5e5b8, aEvent=0x416717e8) at nsXBLPrototypeHandler.cpp:436
#7  0x4148d7e4 in nsXBLPrototypeHandler::BindingDetached(nsIDOMEventReceiver*)
(this=0x8b5b630, aReceiver=0x8a5e5b8)
    at nsXBLPrototypeHandler.cpp:548
#8  0x41477342 in nsXBLPrototypeBinding::BindingDetached(nsIDOMEventReceiver*)
(this=0x8b5a950, aReceiver=0x8a5e5b8)
    at nsXBLPrototypeBinding.cpp:389
#9  0x4147329f in nsXBLBinding::ExecuteDetachedHandler() (this=0x86c77e8) at
nsXBLBinding.cpp:863
#10 0x4149785c in ExecuteDetachedHandler (aTable=0x8a227fc, aHdr=0x8b3eec4,
aNumber=12, aClosure=0x0)
    at nsBindingManager.cpp:940
#11 0x407ab4f2 in PL_DHashTableEnumerate (table=0x8a227fc, etor=0x41497820
<ExecuteDetachedHandler>, arg=0x0)
    at pldhash.c:619
#12 0x4149789e in nsBindingManager::ExecuteDetachedHandlers() (this=0x8a227e8)
at nsBindingManager.cpp:950
#13 0x41d6b3a0 in GlobalWindowImpl::HandleDOMEvent(nsIPresContext*, nsEvent*,
nsIDOMEvent**, unsigned, nsEventStatus*) (
    this=0x8b11dc0, aPresContext=0x8b3a4b8, aEvent=0xbfffea00,
aDOMEvent=0xbfffe9b4, aFlags=7, aEventStatus=0xbfffea3c)
    at nsGlobalWindow.cpp:820
#14 0x41242153 in DocumentViewerImpl::Unload() (this=0x8a62040) at
nsDocumentViewer.cpp:993
#15 0x41ba6a58 in nsDocShell::FireUnloadNotification() (this=0x8b11bf8) at
nsDocShell.cpp:825
#16 0x41ba6af8 in nsDocShell::FireUnloadNotification() (this=0x8aad890) at
nsDocShell.cpp:833
#17 0x41bafef9 in nsDocShell::Destroy() (this=0x8aad890) at nsDocShell.cpp:3014
#18 0x41bdd83c in nsWebShell::Destroy() (this=0x8aad890) at nsWebShell.cpp:1261
#19 0x41838025 in nsXULWindow::Destroy() (this=0x8aad320) at nsXULWindow.cpp:490
#20 0x41858ebc in nsWebShellWindow::Destroy() (this=0x8aad320) at
nsWebShellWindow.cpp:1672
#21 0x4182d1dc in nsChromeTreeOwner::Destroy() (this=0x8aad2a0) at
nsChromeTreeOwner.cpp:293
#22 0x41d75cb6 in GlobalWindowImpl::ReallyCloseWindow() (this=0x8aafe90) at
nsGlobalWindow.cpp:3488
#23 0x41d7a165 in GlobalWindowImpl::CloseWindow(nsISupports*)
(aWindow=0x8aafe94) at nsGlobalWindow.cpp:4615
#24 0x41d5a7b7 in nsJSContext::ScriptEvaluated(int) (this=0x8ab2400,
aTerminated=1) at nsJSEnvironment.cpp:1708
#25 0x41d59817 in nsJSContext::CallEventHandler(void*, void*, unsigned, void*,
int*) (this=0x8ab2400, aTarget=0x8a1fc98,
    aHandler=0x824ce18, argc=2, argv=0x8a811f8, aBoolResult=0xbfffeea8) at
nsJSEnvironment.cpp:1263
#26 0x41d7b09d in GlobalWindowImpl::RunTimeout(nsTimeoutImpl*) (this=0x8aafe90,
aTimeout=0x8a6c5b0)
    at nsGlobalWindow.cpp:4955
#27 0x41d7bccd in GlobalWindowImpl::TimerCallback(nsITimer*, void*)
(aTimer=0x8720818, aClosure=0x8a6c5b0)
    at nsGlobalWindow.cpp:5315
#28 0x4082634a in nsTimerImpl::Fire() (this=0x8720818) at nsTimerImpl.cpp:382
---Type <return> to continue, or q <return> to quit---
#29 0x40826530 in handleTimerEvent(TimerEventType*) (event=0x8b18798) at
nsTimerImpl.cpp:447
#30 0x4081ead0 in PL_HandleEvent (self=0x8b18798) at plevent.c:671
#31 0x4081e971 in PL_ProcessPendingEvents (self=0x813e3c8) at plevent.c:606
#32 0x40820fea in nsEventQueueImpl::ProcessPendingEvents() (this=0x813e140) at
nsEventQueue.cpp:391
#33 0x4189df54 in event_processor_callback (data=0x813e140, source=4,
condition=GDK_INPUT_READ) at nsAppShell.cpp:187
#34 0x4189d8bd in our_gdk_io_invoke (source=0x8227808, condition=G_IO_IN,
data=0x8228788) at nsAppShell.cpp:72
#35 0x4030d7d6 in g_io_channel_unix_get_fd () from /usr/lib/libglib-1.2.so.0
#36 0x403103ee in g_idle_remove_by_data () from /usr/lib/libglib-1.2.so.0
#37 0x40310199 in g_idle_remove_by_data () from /usr/lib/libglib-1.2.so.0
#38 0x4030f174 in g_main_run () from /usr/lib/libglib-1.2.so.0

Will confirm in a moment, after I reproduce the sequence which caused the crash.
Steps to reproduce:
(0) Initial conditions:  Disable XUL cache (Edit, Preferences, Debug,
Networking) is off.
(1) Open Preferences dialog box and check the Disable XUL cache checkbox.
(2) Click "OK".

Expected result:  Disable XUL cache is set, program continues normally.
Actual result: crash.

After restarting Mozilla, preferences dialog will show that the XUL cache is
disabled.  So that part did happen.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

*** This bug has been marked as a duplicate of 228730 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.