If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Build failure in mozilla code while building libgkgfx.so.

RESOLVED FIXED

Status

Core Graveyard
GFX
--
blocker
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Shanmu, Assigned: roc)

Tracking

({regression})

Trunk
DEC
OSF/1
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.6b) Gecko/20031211
Build Identifier: Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.6b) Gecko/20031211

Starting Jan.10th the mozilla code fails to build
with the following errors while building nsRegion.cpp.

cxx: Error: ../../dist/include/gfx/nsRegion.h, line 73: class
          "nsRegion::nsRectFast" has no member "operator="
      nsRectFast::operator = (aRect);               // Copy only the nsRectFast part
------------------^
cxx: Info: 1 error detected in the compilation of "nsRegion.cpp".


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Build failed

Expected Results:  
Should have built successfully.

Comment 1

14 years ago
regression from bug 228378. Did you later test compiling as it seems bug 228378
comment 16 seems to mention a fix for IRIX, AIX, HP-UX, which may have also
fixed OSF/1. There's also patch for bug 230118 that was later backed out.
Keywords: regression
Shanmugavelu, can you try changing "nsRectFast::operator = (aRect);" to
"nsRect::operator = (aRect);" and see if that compiles?
(Reporter)

Comment 3

14 years ago
I tried to compile with the change

nsRect::operator = (aRect);

But still it fails to compile with the same errors.
cxx: Error: ../../dist/include/gfx/nsRegion.h, line 73: class "nsRect" has no
          member "operator="
      nsRect::operator = (aRect);               // Copy only the nsRectFast part
--------------^
cxx: Info: 1 error detected in the compilation of "nsRegion.cpp".

This happens with the latest code.
This must be a compiler bug. nsRect and nsRectFast should have an implicit
operator=. You could try defining the obvious operator= in nsRect.h
*** Bug 231041 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
"You could try defining the obvious operator= in nsRect."

nice. did somebody do try this?
success? patch??

thanks
Created attachment 139275 [details] [diff] [review]
fix

Try this

Comment 8

14 years ago
hello,

patch works!

THANKS!!!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: general → roc
Attachment #139275 - Flags: superreview?(dbaron)
Attachment #139275 - Flags: review?(dbaron)
Attachment #139275 - Flags: superreview?(dbaron)
Attachment #139275 - Flags: superreview+
Attachment #139275 - Flags: review?(dbaron)
Attachment #139275 - Flags: review+
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.