Closed Bug 230745 Opened 18 years ago Closed 17 years ago

Arrow keys and PageUp/PageDown inoperative after loading page in background

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tringali, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The arrow keys, spacebar, and page up/page down cease to work after I open a
page in the background.  If the page has text fields, then the arrow keys fail
to work in it, too.  From thereon, all arrow keys in that tab fail to work even
if you go to a new page.

If I disable "open links in background", the problem does not occur.

The problem seems to be tied to how fast a page loads.  If a page loads quickly
I rarely have a problem.  But I have a slow PC (P2-300) and some pages are large
Bugilla queries.


Reproducible: Sometimes

Steps to Reproduce:
1. Start up on http://bugzilla.mozilla.org/
2. Memorize a large query and put it in your page footer.  It should take a few
seconds (at least 5) to load and be more than one screenful.
3. Start a fresh window (Ctrl+N) on http://bugzilla.mozilla.org/
4. Middle-click on the new query link in the footer, to load it in the
background of a new tab. ("Open In New Tab" does the same thing.)
5. Wait for page to finish loading, switch to the tab.  
6. Press PageDown to scroll.


Actual Results:  
Nothing.


Expected Results:  
Scroll one page down.

This is a bit intermittent.  If it fails to reproduce, close the open tab with
the "X" button, go back to step 4.

In my case, it fails 100% of time when I query our local Bugzilla database.  If
I use Mozilla's, it happens less often, maybe 50%.

My other relevant prefs are set:

  [ ] Move system caret... (no idea what this does)
  [X] Use find as you type...
      [x] to search links...

  [X] Hide tab bar...
  [X] Open links in background
I'm pretty sure the page you mention (http://bugzilla.mozilla.org/) is causing
the bug for a different reason, since you can load it in the foreground and
it'll still interfere with page up/down scrolling.

The reason is that the form on the page is taking the focus
('document.forms['f'].id.focus()'), and this also steals all usage of page
up/down and the arrow cursors. If you click outside the text box, and remove the
focus, then scrolling works again.

Can you reproduce this with any pages that don't focus the cursor? If not, I'm
pretty sure what I said is correct.

This is also an issue with the standard Mozilla browser, and it looks to me like
a dupe of bug 27771.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Actually, inside the BZ home page works just like expected.  The search field
has the focus, and if I press the up/down arrow it activates the history.  If I
click outside of the arrow, then I can scroll the page.  But if I load a link in
the background, then all the arrow keys are gone for all tabs, except for the
original one.

I still stand by my observation that it's a problem with background loading.  If
I turn off the preference, then there are no problems with the arrow keys at all.

In the example I give, the page I'm loading in the background (the bug list
page) doesn't have the focus() thing inside it!

I've read the other bug report, and I'm not sure if this is a duplicate.
You're right, this isn't a dup of bug 124750.  I didn't read your bug report
carefully... sorry about that.  Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608
Firefox/0.8.0+

I've experienced this problem w/ loading bugzilla queries in the background as
well. Haven't found any other sites that cause the problem, but I have noticed a
few other things that seem to suggest there's a problem w/ the actual browser
code that this site is somehow triggering:

1) Any pages loaded in the same tab after the bugzilla query will exhibit the
same problem.
2) Try closing the tab, then opening a new one; the new tab will still have the
problem, as will any further tabs in the same window.
3) An odd workaround for the problem - hit ctrl+F to bring up a find dialog,
then close it. All open problematic tabs work normally again.

I've tested/verified all these symptoms on 2 different winXP machines running
fresh installs/user profiles.
Addendum: Just realized that ctrl+F isn't the only fix: any action that switches
focus to a different window (switch to different app, to dialog window, etc, not
just to a different tab) will fix the problem as well.
I'm unable to reproduce on the latest branch Firefox builds. I'm testing on winXP. 
I'm using 0.9.3 and this is still a problem. Ctrl-F solves the problem indeed,
but it is still very annoying.
works for me with Firefox branch build 2004-09-17-09-0.9
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago17 years ago
Resolution: --- → WORKSFORME
Did you confirm that it was fixed on the trunk as well?
You need to log in before you can comment on or make changes to this bug.