If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DNS: URL cannot be resolved

RESOLVED INCOMPLETE

Status

()

Core
Networking
RESOLVED INCOMPLETE
14 years ago
5 years ago

People

(Reporter: Jim Brown, Unassigned)

Tracking

Trunk
DEC
OSF/1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.7a) Gecko/20040110
Build Identifier: Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.7a) Gecko/20040110

URL cannot be resolved.  I get 'acquire_identify_engage.typepad.com could not be
found.  Please check the name and try again.'.  host -a
acquire_identify_engage.typepad.com results in a valid ip address.  Why doesn't
this URL work with mozilla?


Reproducible: Always

Steps to Reproduce:
1. Try above URL
2. Not error message

Comment 1

14 years ago
WFM - 10 hours old based trunk build - WinXP-Sp1.
WFM on Linux as well...
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc

Comment 3

14 years ago
It works for me on Mac OS X, but that isn't a valid hostname.

You can't use underscores in hostnames.
(Reporter)

Comment 4

14 years ago
So mozilla will only accept/resolve 'valid' hostnames even though simple DNS
utilities (e.g. nslookup, host) will resolve the 'invalid' hostname?
Is there any workaround to get mozilla to even try this name?

Comment 5

14 years ago
There might be a difference in API usage between programs. Darin and any crack
OSF/1 contributors can probably figure that out.
Summary: URL cannot be resolved → DNS: URL cannot be resolved

Comment 6

13 years ago
RFC 1033 appears to allow underscores in host names (possibly an oversight), 
but RFC 3467 disallows them. (I may be wrong, but I think that RFC 952 is still 
the working definition, though RFC 821 and its successors also deal with it).
This has been hashed over many times in various fora as a search on Google will
show.

Unless there are 'phishing' implications should not the basic rule of being
liberal in what one accepts imply that Mozilla should accept any DNS resolvable
host name? Having said that, the tendency seems to be in the direction of greater 
rigour.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 8

12 years ago
Comment 4 should be answered before this is closed. Personally, I think that 
we should adhere to the letter of RFC 3467, but maybe a liberal 'acceptance
policy' is wanted ...

Comment 9

12 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050929
Firefox/1.6a1

Updated

11 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Is this still an issue with recent builds ?
marking incomplete
True64 supports ends today
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.