If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect SMTP sent when sending from non-default SMTP

RESOLVED DUPLICATE of bug 235762

Status

Thunderbird
Account Manager
--
major
RESOLVED DUPLICATE of bug 235762
14 years ago
7 years ago

People

(Reporter: Steve Cohen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

I am trying to set up several identities.  One of my non-default identities is
to a mail provider at a web-hosting facility where they host an account for me.
 Thus, the email address domain is different from the domain of the smtp server.
The email address might be fred@myvanitydomain.org.  But the smtp is at
smtp.webhostinc.com where webhostinc.com hosts myvanitydomain.org.  

I set up an account in Thunderbirdfor this identity and set it up not to use my
default SMTP address but one I've set up for smtp.webhost.com.  The incoming pop
is at mail3.webhostinc.com.
Incoming works just fine.  Outgoing does not.  I get the following message:

"Sending of message failed.
An error occurred sending mail.  Unable to connect to SMTP server
smtp.webhostinc.com.  The server may be down or incorrectly configured.  Please
verify that your Mail/News account settings are correct and try again."

(There is nothing wrong with the server.  I send an email at the same SMTP
server from KMail and it works fine).

Following your suggestion of configuring for log input shows me only 

"SMTP connecting to: smtp.webhostinc.com".  

That's the only line in the log.

My suspicion is that you're doing something wrong with the password.  In Kmail,
there is more the user has to do to set up the use of passwords in SMTP than
what Thunderbird requires.  I think that somehow you may not be not sending the
correct password.

I should say parenthetically that this works better than my last experiences
with Mozilla Mail, where it didn't even get the FROM address right in this use
case.  Thunderbird at least handles that correctly.  


Reproducible: Always

Steps to Reproduce:
1.  You need an email account at a web hoster such that the email address domain
differs from the smtp server domain.
2.  You set up an account using a non-default smtp server.
3.  Send a message using this account

Actual Results:  
Get the error message shown above

Expected Results:  
sent the message correctly

Comment 1

14 years ago
In the "Advanced Outgoing Sever (SMTP) Settings" dialogue box, NO matter which
SMTP server is set default, always the first/top SMTP server in the list is
used. Fail as a different ISP is used.

Comment 2

14 years ago
bug still there in thunderbird 0.5. 
 
specifying multiple smpt severs is VERY non-intuitive compared to outlook, 
evolution, staroffice mailer. 
 

Comment 3

14 years ago
Is Thunderbird still uses wrong SMTP server after restart?
If not, this is a dup of bug 170089
version 0.8 (20040913) on windows XPsp2

when we add additional identities, a smtp servers are already set and we have 
choose to use a specific smtp for this specific account, we can see in prefs.js 
files:

user_pref "mail.account.account2.identities", "id1,id2,id3,id4,id5,id6");
user_pref("mail.smtp.defaultserver", "smtp4");
user_pref("mail.smtpservers", "smtp4,smtp1,smtp2");
user_pref("mail.identity.id1.smtpServer", "smtp1");
user_pref("mail.identity.id2.smtpServer", "smtp1");
user_pref("mail.identity.id3.smtpServer", "smtp1");
...

then if we choose to change the smtp setting for the account in 'use the 
default smtp' the prefs.js will change in:

user_pref("mail.identity.id1.smtpServer", "");
user_pref("mail.identity.id2.smtpServer", "smtp1");
user_pref("mail.identity.id3.smtpServer", "smtp1");

so the only little mistake is that the GUI can change only the first id for 
every account and not the additional identities.
manually change the .js and go!!!!!!!

coders dont use drugs ;)

Comment 5

13 years ago
I have the same, 
actually I'm using a few difrent account's and want to use smpt in most of them.
When (in gui compose message) i choose smtp i'd like to use, but i can't send it
seeing massage like reporter shown. 

Comment 6

13 years ago
I have the same, 
actually I'm using a few difrent account's and want to use smpt in most of them.
When (in gui compose message) i choose smtp i'd like to use, but i can't send it
seeing massage like reporter shown. 
And it is in _thunderbird 1.0_ 
(In reply to comment #4)
> when we add additional identities, a smtp servers are already set and we have 
> choose to use a specific smtp for this specific account, we can see in prefs.js 
> files:
This is done by patch for Bug 235762(fixed on 2004-09-28 13:15 PDT), 
and problem is resolved if identy is newly defined.
So problems in comment #0 to comment #3 was already fixed.

> then if we choose to change the smtp setting for the account in 'use the 
> default smtp' the prefs.js will change in:
>  user_pref("mail.identity.id1.smtpServer", "");
>  user_pref("mail.identity.id2.smtpServer", "smtp1");
>  user_pref("mail.identity.id3.smtpServer", "smtp1");
> so the only little mistake is that the GUI can change only the first id for 
> every account and not the additional identities.
> manually change the .js and go!!!!!!!

Bug 272354 is probably this problem since opened on 2004/11/29(Bug 235762 is
already fixed).
I think we'd be better to close this bug as DUP of Bug 235762 and to analyze
post Bug 235762 problems in Bug 272354.
I'm asking on this in Bug 272354 Comment #5 to reporter of the bug and other
comment posters.
And your comment proved that answer is "yes".
Ilona Gaweda, could you add a comment to Bug 272354 on your above result, please.
Bug 272354 was closed as DUP of Bug 235762, and new Bug 277998 has been opened
for remaining problem.
Closing this bug as DUP of Bug 235762, since one problem per bug.
See Bug 277998 for remaing comment #4 & comment #7 problem.

*** This bug has been marked as a duplicate of 235762 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.