Many PDF links result in "Sorry about that..." error.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: kerry, Unassigned)

Tracking

({testcase})

Trunk
PowerPC
Mac OS X
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925

If you click on the second link in my sample page...

   http://www.shetline.com/misc/pdf_test.html

...you'll see what I mean. A modal dialog pops up with the error message:

"Path/to/where/Mozilla/tries/to/save/file.pdf could not be opened because an
unknown error occurred.

Sorry about that. Try saving to disk first and then opening the file."

Not only is this a poor work-around for something that works file in Safari and
Mozilla, but there are cases were it does not work. One case that I frequently
run into (which I can't give you a link for, for obvious reasons) is one my
bank's web site, when I tried to view a PDF file of one of my cancelled checks.
The link is a JavaScript link, and trying to save the link target doesn't work.

What I think I've discovered with my test web page is that GET parameters throw
off Mozilla's ability to properly save (and then open) a PDF file. In my
example, the GET info is superfluous, but in the case of my bank web site, the
GET parameters are necessary info for a CGI that provides the PDF file.

This link works:

   <a href="U0100.pdf" target="_blank">

And this doesn't:

   <a href="U0100.pdf?foo=bar" target="_blank">

The "?foo=bar" part shouldn't matter at all to the browser client in how it
handles the data that comes back.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.shetline.com/misc/pdf_test.html
2. Click on the second link.
3. There is no step 3! :)

Actual Results:  
Error as described above.

Expected Results:  
Simply have shown the PDF.

I played around with setting explicit Helper Application preferences for PDF
MIME types and extensions, but that didn't help.
Sounds like bug 166369.  Please retest with a build that has those patched in it
(eg 1.6b).

Comment 2

15 years ago
the second links works fine for me using 20041012 on Win2k (and Acrobat Reader 6).
as per comment 1, can you try latest pre-1.6 build ?
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.6/
Keywords: testcase
(Reporter)

Comment 3

15 years ago
I reported this bug for Mac OS 10.3, and that's the only scope I'm claiming for
the bug... I haven't seen this bug on Windows.

Comment 4

15 years ago
Works fine with a 20040109 nightly build on Mac OS 10.2.1. Kerry, please try a
more recent build and report back - this is probably fixed (see comment #1 and #2).
Assignee: general → file-handling
Component: Browser-General → File Handling
QA Contact: general → ian

Comment 5

14 years ago
There used to be a cluster of Mac download bugs with the "Sorry about that"
error. They were all fixed. This bug is a dupe of one of them, but I don't know
which.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.