mozilla forgets position in page after open ing new page and using back button

VERIFIED DUPLICATE of bug 36539

Status

()

defect
VERIFIED DUPLICATE of bug 36539
16 years ago
a month ago

People

(Reporter: mozilla-bugs, Assigned: aaronlev)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Not so much a bug as an accessibility issue:

When navigating with the keyboard, not the mouse, the current cursor position in
the page is important. When I navigate to a link by clicking ta repeatedly, then
select it with enter, and then go back from the new back (using backspace),
mozilla does not remember the link i was on - instead, tabbing starts at the top
of the page again. This makes navigating a large number of links (say google
results) very tedious.

Internet Explorer OTOH seems to remember the state of the cursor on the page for
all the pages in the 'back' history stack, which significantly eases keyboard
navigation.

Reproducible: Always

Steps to Reproduce:
1. search with google
2. use the keyboard (tab) to navigate to the first search result, open it
3. go back to the page with the results
4. press tab. notice how you're not on the next link, but on the first link of
the page again.

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.